其他分享
首页 > 其他分享> > HDOJ 1093

HDOJ 1093

作者:互联网

A+B for Input-Output Practice (V)
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 131049 Accepted Submission(s): 86297

Problem Description
Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input
2
4 1 2 3 4
5 1 2 3 4 5

Sample Output
10
15

Author
lcy

解题思路
喝汤一样

AC

#include<iostream>
using namespace std;
int main()
{
	int n1, n2, temp, ans;
	while (cin >> n1) {
		while (n1--) {
			cin >> n2;
			ans = 0;
			for (int i = 0; i < n2; i++) {
				cin >> temp;
				ans += temp;
			}
			cout << ans << endl;
		}
	}
	return 0;
}

标签:1093,int,Output,ans,Input,line,n2,HDOJ
来源: https://blog.csdn.net/weixin_45778081/article/details/113782063