其他分享
首页 > 其他分享> > Red and Black(DFS)

Red and Black(DFS)

作者:互联网

题目:

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

思路:DFS

实现代码:

#include<cstdio>
#include<cstring>
using namespace std;
int w,h,sum;
char map[22][22];
int dis[4][2]={{1,0},{-1,0},{0,-1},{0,1}};

void dfs(int x,int y)
{
	int nx,ny,i; 
	map[x][y]='#';
    sum++;
	for(i=0;i<4;i++)
	{
		nx=x+dis[i][0];
		ny=y+dis[i][1];
		if(map[nx][ny]!=0&&map[nx][ny]!='#')
		 dfs(nx,ny);
	}
}
int main()
{
	int i,j,p,q;
	while(~scanf("%d %d",&w,&h))
	{
		getchar();
		if(w==0&&h==0)
		break;
		memset(map,0,sizeof(map));
		for(i=1;i<=h;i++)
		{
			for(j=1;j<=w;j++)
			{
				scanf("%c",&map[i][j]);
				if(map[i][j]=='@')
				{
					p=i;
					q=j;
				}
			
			}
			getchar();
		}
		sum=0;

		dfs(p,q);
		printf("%d\n",sum);
	}
    return 0;
} 

注意:用这种提前把地图(题中所给的最大范围)所有都标记为0,然后输入我们要搜索的地图,直接在地图上更改的,要注意定义的大小!!这里char map[22][22],不可以是21!!大于22也可。for for的输入,也是从i=1,j=1,开始哦,相当于我们把最大范围20外面围了个0的圈子,所以是22。

标签:tiles,22,int,DFS,Black,tile,black,Red,he
来源: https://blog.csdn.net/with_wine/article/details/113774594