其他分享
首页 > 其他分享> > 1043 Is It a Binary Search Tree (25 分)

1043 Is It a Binary Search Tree (25 分)

作者:互联网

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11
 

Sample Output 1:

YES
5 7 6 8 11 10 8
 

Sample Input 2:

7
8 10 11 8 6 7 5
 

Sample Output 2:

YES
11 8 10 7 5 6 8
 

Sample Input 3:

7
8 6 8 5 10 9 11
 

Sample Output 3:

NO


题意:
判断一个序列是否为二叉搜索树的先序序列或者二叉搜索树镜像的先序序列,若是,则输出后序序列。

方法一:
结构体+指针:
建立一棵二叉搜索树,先序遍历,再对照,若相等,则是
至于是否为其镜像,只需改变先序中遍历左子树和右子树的顺序即可,相应的后序遍历也是!!
#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;
typedef struct TreeNode {
    int v;
    struct TreeNode *Left,*Right;
    int flag;
}TreeN,*Tree;
int m[maxn];
int n;
queue<int> q,p;
int ct=0,ct2=0;
void Insert(Tree &T,int V){
    if(!T){
        T=new TreeN;
        T->v=V;
        T->Left=NULL;
        T->Right=NULL;
        T->flag=0;
    }
    else{
        if(V<T->v){
            Insert(T->Left,V);
        }
        else{
            Insert(T->Right,V);
        }
    }

}
void MakeTree(Tree &T){
    T=new TreeN;
    T->v=m[0];
    T->Left=NULL;
    T->Right=NULL;
    T->flag=0;
    for(int i=1;i<n;i++){
        Insert(T,m[i]);
    }
}

void proOrder(Tree T){
    //先序,先左后右
    if(T){
//        printf("%d ",T->v);
        q.push(T->v);
        proOrder(T->Left);
        proOrder(T->Right);
    }
}
void proOrder2(Tree T){
    //先序,先右后左
    if(T){
//        printf("%d ",T->v);
        p.push(T->v);
        proOrder2(T->Right);
        proOrder2(T->Left);
    }
}
void Post(Tree T){
    //后序,先左后右
    if(T){
        Post(T->Left);
        Post(T->Right);
        if(ct<n-1)
        {
            printf("%d ",T->v);
        }
        else{
            printf("%d\n",T->v);
        }
        ct++;
    }
}
void Post2(Tree T){
    //后序,先右后左
    if(T){
        Post2(T->Right);
        Post2(T->Left);
        if(ct2<n-1)
        {
            printf("%d ",T->v);
        }
        else{
            printf("%d\n",T->v);
        }
        ct2++;
    }
}
int main(){
    Tree T;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d",&m[i]);
    }
    MakeTree(T);
    proOrder(T);
    proOrder2(T);
    int len=q.size();
    int flag1=1,flag2=1;
    for(int i=0;i<len;i++){
        if(q.front()!=m[i]){
            flag1=0;
            break;
        }
        q.pop();
    }
    for(int i=0;i<len;i++){
        if(p.front()!=m[i]){
            flag2=0;
            break;
        }
        p.pop();
    }
    
    if(flag1==1){
        printf("YES\n");
        Post(T);
    }
    else if(flag2==1){
        printf("YES\n");
        Post2(T);
    }
    else if(flag1==0&&flag2==0){
        printf("NO\n");
    }
    return 0;
}

 

方法二:

 



标签:1043,Binary,Search,Right,int,Tree,BST,line,Left
来源: https://www.cnblogs.com/dreamzj/p/14391498.html