其他分享
首页 > 其他分享> > hdu2612 Find a way

hdu2612 Find a way

作者:互联网

Find a way

hdu2612

题目

Description

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input

The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF

Output

For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input

4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#

Sample Output

66
88
66

题目大意

Y和M要在KFC约会,地图上有多个KFC,求在哪个KFC两人所走总距离最短,(注意KFC可以当做路)

解题思路

本题的陷井在于:1.Y不能走M的位置并且M不能走Y的位置 2.每个@必须被Y和M分别访问一次才能是正确的时间值。

代码

#include<iostream>
#include<queue>
#define N 210
#define inf 0xffffff
using namespace std;
int m,n,mark[N][N],dis[N][N][2],dir[4][2]={1,0, 0,1, -1,0, 0,-1},flag;
char s[N][N];
struct node{
   int x,y,step;
};
bool judge(int x,int y)
{
   if(x>=0 && x<m && y>=0 && y<n && s[x][y]!='#' && mark[x][y]==0)
      return 1;
   return 0;
}
void bfs(int x,int y)
{
   int k;
  queue<node>q;
  node cur,next;
  cur.x=x;cur.y=y;cur.step=0;
   mark[x][y]=1;
   q.push(cur);
   while(!q.empty())
   {
      cur=q.front();
      q.pop();
      next.step=cur.step+1;
      for(k=0;k<4;k++)
      {
         next.x=x=cur.x+dir[k][0];
         next.y=y=cur.y+dir[k][1];
         if(judge(x,y))
          {
             mark[x][y]=1;
             if(s[x][y]=='@')
                dis[x][y][flag]=next.step;
             q.push(next);
          }
      }
   }
}

int main()
{
   int i,j,min;
   while(scanf("%d %d",&m,&n)!=-1)
   {
      min=inf;
      for(i=0;i<m;i++)
         for(j=0;j<n;j++)
             dis[i][j][0]=dis[i][j][1]=inf;

      for(i=0;i<m;i++)
         scanf("%s",s[i]);
      for(i=0;i<m;i++)
         for(j=0;j<n;j++)
          {
             if(s[i][j]=='Y')
             {
                flag=0;
                memset(mark,0,sizeof(mark));
                bfs(i,j);
             }
             else if(s[i][j]=='M')
             {
                flag=1;
                memset(mark,0,sizeof(mark));
                bfs(i,j);
             }
          }
      for(i=0;i<m;i++)
         for(j=0;j<n;j++)
             if(s[i][j]=='@' && min>dis[i][j][0]+dis[i][j][1])
                min=dis[i][j][0]+dis[i][j][1];
         printf("%d\n",min*11);
   }
   return 0;
}

标签:cur,Merceki,hdu2612,Ningbo,KFC,way,dis,Find,yifenfei
来源: https://www.cnblogs.com/Jernewson/p/14391318.html