其他分享
首页 > 其他分享> > A-1025 PAT Ranking (25 分)

A-1025 PAT Ranking (25 分)

作者:互联网

A-1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

#include <string>
#include <iostream>
#include <algorithm>
using namespace std;

struct hello{
    string num;//准考证号
    int fen,pz,pf;//分数,总排名,分排名
    int lo;//考场
}stu[30000];//最多有30000个考生
bool cmp(hello a,hello b){//比较函数
    if(a.fen!=b.fen)return a.fen>b.fen;//按分数大小排名
    else return a.num<b.num;//分数相同按准考证号排名
}
int main(){
    int n,m,i,j,k=0,p;
    cin >> n;//考场数
    for(i=0;i<n;i++){
        cin >> m;//该考场内的人数
        for(j=0;j<m;j++){
            cin >> stu[k].num >> stu[k].fen;
            stu[k].lo=i+1;//考场号为i+1
            k++;//记录总共的人数
        }
        sort(stu+k-m,stu+k,cmp);//对该考场进行排名
        for(j=0;j<m;j++){//将考场排名结果记录到每个学生的信息中
            if(stu[k-m+j].fen==stu[k-m+j-1].fen){
                stu[k-m+j].pf=stu[k-m+j-1].pf;
            }else stu[k-m+j].pf=j+1;
        }
    }
    sort(stu,stu+k,cmp);//对所有人进行总排名
    for(i=0;i<k;i++){//将总排名结果记录到每个学生的信息中
        if(stu[i].fen==stu[i-1].fen){
            stu[i].pz=stu[i-1].pz;
        }else stu[i].pz=i+1;
    }
    cout << k << endl;//输出
    for(i=0;i<k;i++){
        cout << stu[i].num;
        printf(" %d %d %d\n",stu[i].pz,stu[i].lo,stu[i].pf);
    }
    return 0;
}

标签:1025,Ranking,PAT,考场,fen,number,stu,each,test
来源: https://blog.csdn.net/GCWsuger/article/details/113758665