其他分享
首页 > 其他分享> > nyoj 1018(ZKNUOJ 1018)

nyoj 1018(ZKNUOJ 1018)

作者:互联网

Description

一球从M米高度自由下落,每次落地后返回原高度的一半,再落下。 它在第N次落地时反弹多高?共经过多少米? 保留两位小数

Input

M N

Output

它在第N次落地时反弹多高?共经过多少米? 保留两位小数,空格隔开,放在一行

Sample Input
1000 5

Sample Output
31.25 2875.00

#include<stdio.h>
int main(){
	float M;
	int N;
	scanf("%f %d",&M,&N);
		float length = M;//总距离
	for(int i = 1;i <= N;i++){
		M = M/2;
		length = length + M*2;
	}
	// 别忘了减去第N次弹起和落下来的2M距离
	length = length - 2*M;
	printf("%.2f %.2f",M,length);
}

标签:%.,int,float,ZKNUOJ,nyoj,2f,length,1018,Input
来源: https://blog.csdn.net/L51213/article/details/112738255