CCF CSP 202009-1 称检查点查询
作者:互联网
202009-1 称检查点查询
题目背景
2020年6月8日,国务院联防联控机制发布《关于加快推进新冠病毒核酸检测的实施意见》,提出对“密切接触者”等八类重点人群“应检尽检”,其他人群“愿检尽检”。
问题描述
某市设有n个核酸检测点,编号从1到n,其中i号检测点的位置可以表示为一个平面整数坐标(\(x_i,y_i\))。为方便预约核酸检测,请根据市民所在位置(X,Y),查询距其最近的三个检测点。
多个检测点距离相同时,编号较小的视为更近。
输入格式
输出共三行,按距离从最近到远,依次输出距离该市民最近的三个检测点编号。
样例输入1
3 2 2
2 2
2 3
2 4
样例输出1
1
2
3
样例输入2
5 0 1
-1 0
0 0
1 0
0 2
-1 2
样例输出2
2
4
1
评测用例规模与约定
全部的测试点满足,\(3\le n \le200\),所有坐标均为整数且绝对值不超过1000。
提示
市民到第i号检测点的距离\(D_i\)可由如下公式算出:
\[D_i^2=(X-x_i)^2+(Y-y_i)^2 \]代码
#include<iostream>
#include<cstdio>
#include<algorithm>
struct Node {
int dest;
int no;
}position[201];
bool compare(Node a,Node b){
if(a.dest != b.dest)
return a.dest < b.dest;
else if(a.no != b.no)
return a.no < b.no;
}
int main(){
int n,x,y;
scanf("%d %d %d",&n,&x,&y);
int i,xi,yi;
for ( i= 0; i < n; ++i)
{
scanf("%d %d", &xi, &yi);
position[i].dest=(x-xi)*(x-xi)+(y-yi)*(y-yi);
position[i].no=i+1;
}
std::sort(position,position+n,compare);
for(int i = 0 ; i < 3;i++)
{
printf("%d\n",position[i].no);
}
return 0;
}
标签:yi,CCF,no,dest,int,检查点,position,检测点,CSP 来源: https://www.cnblogs.com/zhangzizi/p/14263820.html