其他分享
首页 > 其他分享> > PTA甲级 1068 Find More Coins (30point(s))

PTA甲级 1068 Find More Coins (30point(s))

作者:互联网

强烈推荐,刷PTA的朋友都认识一下柳神–PTA解法大佬

本文由参考于柳神博客写成

柳神的CSDN博客,这个可以搜索文章

柳神的个人博客,这个没有广告,但是不能搜索

还有就是非常非常有用的 算法笔记 全名是

算法笔记  上级训练实战指南		//这本都是PTA的题解
算法笔记

PS 今天也要加油鸭

在这里插入图片描述

题目原文

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤104, the total number of coins) and M (≤102, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V1≤V2≤⋯≤V**k such that V1+V2+⋯+V**k=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output “No Solution” instead.

Note: sequence {A[1], A[2], …} is said to be “smaller” than sequence {B[1], B[2], …} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].

Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8
7 2 4 3

Sample Output 2:

No Solution

生词如下:

PS:词基本都认识

意思也都翻译出来了.

就是买东西.然后你有N个硬币.N个硬币的面值都不同.

然后你要买M块钱的东西.

要求是你必须要用这N个硬币刚刚好凑出M元

如果有好几种选择的方案的话,你要选择.最短的,就是序列号最短的.

代码如下:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 10010;
const int maxv = 110;
int w[maxn], dp[maxv] = { 0 };		//w[i]为钱币的价值
bool choice[maxn][maxv], flag[maxn];
bool cmp(int a, int b) {
	return a > b;
}
int main() {
	int n, m;
	scanf("%d%d", &n, &m);
	for (int i = 1; i <=n; ++i) {
		scanf("%d", &w[i]);
	}
	sort(w + 1, w + n + 1, cmp);
	for (int i = 1; i <= n; ++i) {
		for (int v = m; v >= w[i]; v--) {
			//状态转移方程
			if (dp[v] <= dp[v - w[i]] + w[i]) {	//等于时也要饭
				dp[v] = dp[v - w[i]] + w[i];
				choice[i][v] = 1;				//放入第i件物品
			}
			else
				choice[i][v] = 0;				//不放入第i件物品
		}
	}
	if (dp[m] != m)	printf("No Solution");		//无解
	else {
		//记录最优路径
		int k = n, num = 0, v = m;
		while (k >= 0) {
			if (choice[k][v] == 1) {
				flag[k] = true;
				v -= w[k];
				num++;
			}
			else
				flag[k] = false;
			k--;
		}
		for (int i = n; i >= 1; i--) {
			if (flag[i] == true) {
				printf("%d", w[i]);
				num--;
				if (num > 0)printf(" ");
			}
		}
	}
	return 0;
}

标签:1068,coins,柳神,30point,int,Coins,--,she,line
来源: https://blog.csdn.net/Huangpengyu123/article/details/112134961