1046 Shortest Distance (20point(s))
作者:互联网
1046 Shortest Distance (20point(s))
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10
5]), followed by N integer distances D1 D2⋯ DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10
4), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10
7
.
Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
超时代码
#include<bits/stdc++.h>
using namespace std;
int d[100000+10];
int main(){
int n,m;
int start,end;
cin>>n;
for(int i=1;i<=n;++i){
cin>>d[i];
}
cin>>m;
for(int i=0;i<m;++i){
cin>>start>>end;
if(start>end)
swap(start,end);
int minDis=0,temp=0;
for(int k=start;k<end;++k){
temp+=d[k];
}
for(int k=start-1;k>=1;--k)
minDis+=d[k];
for(int k=end;k<=n;++k)
minDis+=d[k];
minDis=min(minDis,temp);
cout<<minDis<<endl;
}
}
打表
#include<bits/stdc++.h>
using namespace std;
int d[100000+10];
int main(){
int n,m;
int start,end;
cin>>n;
int temp,sum=0;
for(int i=1;i<=n;++i){
cin>>temp;
sum+=temp;
d[i]=sum;
}
cin>>m;
for(int i=0;i<m;++i){
cin>>start>>end;
if(start>end)
swap(start,end);
int t=d[end-1]-d[start-1];
cout<<min(t,sum-t)<<endl;
}
}
标签:Distance,end,1046,exits,10,int,cin,start,20point 来源: https://blog.csdn.net/weixin_44970602/article/details/111055261