1075 链表元素分类 (25分)
作者:互联网
定一个单链表,请编写程序将链表元素进行分类排列,使得所有负值元素都排在非负值元素的前面,而 [0, K] 区间内的元素都排在大于 K 的元素前面。但每一类内部元素的顺序是不能改变的。例如:给定链表为 18→7→-4→0→5→-6→10→11→-2,K 为 10,则输出应该为 -4→-6→-2→7→0→5→10→18→11。
输入格式:
每个输入包含一个测试用例。每个测试用例第 1 行给出:第 1 个结点的地址;结点总个数,即正整数N (≤105);以及正整数K (≤103)。结点的地址是 5 位非负整数,NULL 地址用 −1 表示。
接下来有 N 行,每行格式为:
Address Data Next
其中 Address
是结点地址;Data
是该结点保存的数据,为 [−105,105] 区间内的整数;Next
是下一结点的地址。题目保证给出的链表不为空。
输出格式:
对每个测试用例,按链表从头到尾的顺序输出重排后的结果链表,其上每个结点占一行,格式与输入相同。
输入样例:
00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218
输出样例:
33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1
#include <iostream>
#include <math.h>
#include <algorithm>
#include <stdlib.h>
#include <stdio.h>
#include <iomanip>
#include <string.h>
#include <vector>
#include <set>
#include <map>
#include <iomanip>
#include <string>
#include <sstream>
using namespace std;
struct node
{
int data;
string address;
string next;
};
node ns[100100];
node ad1[100100];
node ad2[100100];
node ad3[100100];
int i1,i2,i3;
int main()
{
i1=i2=i3=0;
string s;
int n,k;
cin>>s>>n>>k;
for(int i=0; i<n; i++)
{
string s1,next;
int d;
cin>>s1>>d>>next;
ns[atoi(s1.c_str())].data=d;
ns[atoi(s1.c_str())].address=s1;
ns[atoi(s1.c_str())].next=next;
}
node ss = ns[atoi(s.c_str())];
while(1)
{
if(ss.data<0)
{
ad1[i1]=ss;
i1++;
}
if(ss.data>=0&&ss.data<=k)
{
ad2[i2]=ss;
i2++;
}
if(ss.data>k)
{
ad3[i3]=ss;
i3++;
}
if(ss.next=="-1")
break;
ss=ns[atoi(ss.next.c_str())];
}
for(int i=0; i<i1; i++)
{
cout<<ad1[i].address<<' '<<ad1[i].data<<' ';
if(i!=i1-1)
cout<<ad1[i+1].address<<endl;
else if(i2>0)
cout<<ad2[0].address<<endl;
else if(i3>0)
cout<<ad3[0].address<<endl;
else
cout<<"-1"<<endl;
}
for(int i=0; i<i2; i++)
{
cout<<ad2[i].address<<' '<<ad2[i].data<<' ';
if(i!=i2-1)
cout<<ad2[i+1].address<<endl;
else if(i3>0)
cout<<ad3[0].address<<endl;
else
cout<<"-1"<<endl;
}
for(int i=0; i<i3; i++)
{
cout<<ad3[i].address<<' '<<ad3[i].data<<' ';
if(i!=i3-1)
cout<<ad3[i+1].address<<endl;
else
cout<<"-1"<<endl;
}
return 0;
}
标签:25,结点,10,ss,1075,next,链表,include 来源: https://blog.csdn.net/qq_43287952/article/details/110661691