其他分享
首页 > 其他分享> > HDU 1004 Let the Balloon Rise

HDU 1004 Let the Balloon Rise

作者:互联网

HDU 1004

Let the Balloon Rise

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

#include<stdio.h>
#include<string.h>
int main(){
	int i,j,n,max,index;
	char color[1005][15];
	//int num[1005]={0}; 要分清全局变量和过程变量,一开始我写在这里,出错了,因为它是全局变量,在下面的++操作中,不会被刷新,重新初始化为0,导致WA
	while(scanf("%d",&n)&&n){
		int num[1005]={0};//写在这里就解决了
		max=0;index=0;//记得初始化参数,老是忘记
		for(i=0;i<n;i++){
			scanf("%s",&color[i]);
			for(j=0;j<=i;j++){
				if(strcmp(color[i],color[j])==0){
					num[j]++;
					if(num[j]>max){
						max=num[j];
						index=j;
					}
					break;
				}
			}
		}
		printf("%s\n",color[index]);
	}
}

Note:

私以为我写的更加简洁一点,在输入的时候就已经遍历了

标签:case,index,HDU,color,Rise,int,test,1004,red
来源: https://www.cnblogs.com/Dios314/p/13972846.html