Codeup——602 | 问题 A: 简单计算器
作者:互联网
题目描述
读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。
输入
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。
输出
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。
样例输入
30 / 90 - 26 + 97 - 5 - 6 - 13 / 88 * 6 + 51 / 29 + 79 * 87 + 57 * 92
0
样例输出
12178.21
思路:先将输入的字符串做去空格处理,然后将其转换为后缀表达式,最后计算这个表达式即可。
#include <iostream>
#include <cstdio>
#include <map>
#include <stack>
#include <queue>
#include <string>
#include <cctype>
using namespace std;
struct node{ //把操作数和操作符定义成结构体,其中flag=true时表示操作数
double num; //操作数
char op; //操作符
bool flag; //true表示操作数,false表示操作符
};
string str; //输入的字符串
stack<node> s; //定义一个栈,用于处理操作符以及后续做计算处理
queue<node> q; //定义一个队列,用于存放后缀表达式
map<char,int> mp; //操作符的优先级
void change(){ //把中缀表达式转换为后缀表达式
node temp;
for(int i=0;i<str.length();){
if(isdigit(str[i])){ //如果是数字
temp.flag=true; //标记
temp.num=str[i++]-'0';
while(i<str.length()&&isdigit(str[i])) //表示有多位
temp.num=temp.num*10+(str[i++]-'0');
q.push(temp); //把操作数入队
}
else{ //如果是操作符
temp.flag=false; //标记
//如果该操作符的优先级小于或者等于栈顶操作符的优先级
//则把栈顶操作符入队,直到栈为空或者是该操作符是栈元素里优先等级最高的那个
while(!s.empty()&&mp[str[i]]<=mp[s.top().op]){ //注意empty要写在前面,编译器不会报错但是OJ时会出现运行错误
q.push(s.top());
s.pop();
}
temp.op=str[i++];
s.push(temp); //把操作符入栈
}
}
while(!s.empty()){ //如果栈中还有多余的操作符,则入队
q.push(s.top());
s.pop();
}
}
double Cal(){ //计算后缀表达式
double temp1,temp2; //temp1表示前面的操作数,temp2表示后面的操作数
node temp,cur;
while(!q.empty()){
cur=q.front(); //记录队首元素
q.pop(); //队首元素被记录后出队
if(cur.flag==true) s.push(cur); //如果是操作数,则压入栈中
else{ //如果是操作符,则一次性从栈中弹出两个操作数
temp2=s.top().num; //栈顶的是后面的操作数
s.pop();
temp1=s.top().num;
s.pop();
temp.flag=true;
if(cur.op=='+') temp.num=temp1+temp2; //加法
else if(cur.op=='-') temp.num=temp1-temp2; //减法
else if(cur.op=='*') temp.num=temp1*temp2; //乘法
else temp.num=temp1/temp2; //除法
s.push(temp); //将该计算后的结果压入栈中
}
}
return s.top().num; //此时栈中只有唯一的元素,该元素即是计算后的结果
}
int main()
{
mp['+']=mp['-']=1; //加号和减号的优先级低
mp['*']=mp['/']=2;
while(getline(cin,str),str!="0"){
int pos=0;
while(1){ //去除多余的空格
pos=str.find(' ');
if(pos==string::npos) break;
str.erase(str.begin()+pos);
}
while(!s.empty()) s.pop(); //初始化栈
change();
printf("%.2lf\n",Cal());
}
return 0;
}
标签:操作数,602,测试用例,操作符,输入,Codeup,计算器,include,表达式 来源: https://blog.csdn.net/qq_44888152/article/details/107025549