其他分享
首页 > 其他分享> > Disease Manangement 疾病管理

Disease Manangement 疾病管理

作者:互联网

Disease Manangement 疾病管理

题目描述

Alas! \(A\) set of \(D (1 <= D <= 15)\) diseases (numbered \(1..D\)) is running through the farm. Farmer John would like to milk as many of his N \((1 <= N <= 1,000)\) cows as possible. If the milked cows carry more than K \((1 <= K <= D)\) different diseases among them, then the milk will be too contaminated and will have to be discarded in its entirety. Please help determine the largest number of cows FJ can milk without having to discard the milk.

输入格式

输出格式

Line 1: M, the maximum number of cows which can be milked.

样例

样例输入

6 3 2
0---------第一头牛患0种病
1 1------第二头牛患一种病,为第一种病.
1 2
1 3
2 2 1
2 2 1

样例输出

5

OUTPUT DETAILS

If FJ milks cows 1, 2, 3, 5, and 6, then the milk will have only two diseases (#1 and #2), which is no greater than K (2).

题解

emmm,状压dp。

code

#include<cstdio>
#include<cstring>
#include<algorithm>
#define ll long long
using namespace std;
const int lqs=1200;
int lim[lqs];
int f[1<<16];
int find(int x){
	int cnt=0;
	while(x){
		x-=x&(-x);
		cnt++;
	}
	return cnt;
}
int main(){
	int n,m,k;
	scanf("%d%d%d",&n,&m,&k);
	for(int i=1;i<=n;i++){
		int t;
		scanf("%d",&t);
		while(t--){
			int a;
			scanf("%d",&a);
			lim[i]|=1<<a-1;
		}
	}
	int Mx=1<<m,ans=0;
	for(int i=1;i<=n;i++)
		for(int s=Mx-1;s;s--){	
			f[s|lim[i]]=max(f[s|lim[i]],f[s]+1);
			if(find(s|lim[i])<=k)ans=max(ans,f[s|lim[i]]);
			//printf("%d %d\n",s|lim[i],f[s|lim[i]]);
		}
	printf("%d\n",ans);
}

标签:种病,diseases,int,样例,Disease,Line,include,疾病,Manangement
来源: https://www.cnblogs.com/hellohhy/p/13198577.html