其他分享
首页 > 其他分享> > Tallest Cow

Tallest Cow

作者:互联网

目录

Tallest Cow(差分)

题目

Description

FJ's N (1 ≤ N ≤ 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.

FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form "cow 17 sees cow 34". This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.

For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

Input

Line 1: Four space-separated integers: N, I, H and R
Lines 2..R+1: Two distinct space-separated integers A and B (1 ≤ A, BN), indicating that cow A can see cow B.

Output

Lines 1..N: Line i contains the maximum possible height of cow i.

Sample Input

9 3 5 5
1 3
5 3
4 3
3 7
9 8

Sample Output

5
4
5
3
4
4
5
5
5

思路

代码

#include<iostream>
#include<algorithm>
using namespace std;
const int N=1e4+10;
int a[N],b[N],vis[N][N];
int n,h,pos,q;
void insertnum(int x,int y)
{
    b[x+1]-=1;
    b[y]+=1;
}

int main()
{
    cin>>n>>pos>>h>>q;
    for(int i=1;i<=n;i++) //就正常 下标 开始就可以了
        a[i]=h;
        for(int i=1;i<n;i++) b[i]=a[i]-a[i-1];
    
    while(q--)
    {
        int x,y;
        cin>>x>>y;
        if(x>y)  swap(x,y);
        if(vis[x][y])
           continue;
        vis[x][y]=1;
        insertnum(x,y);
        
        
    }

    for(int i=1;i<=n;i++)
    
        a[i]=a[i-1]+b[i];
        
    for(int i=1;i<=n;i++) cout<<a[i]<<endl;

    return 0;
}
// 不初始化
#include<iostream>
#include<algorithm>
using namespace std;
const int N=1e4+10;
int a[N],b[N],vis[N][N];
int n,h,pos,q;
void insertnum(int x,int y)
{
    b[x+1]-=1;
    b[y]+=1;
}

int main()
{
    cin>>n>>pos>>h>>q;
    for(int i=0;i<=n;i++)
        a[i]=h;
    
    while(q--)
    {
        int x,y;
        cin>>x>>y;
        if(x>y)  swap(x,y);
        if(vis[x][y])// 看是不是出现过  坑点 
           continue;
        vis[x][y]=1;
        insertnum(x,y);
        
        
    }

    for(int i=1;i<=n;i++)
    
        a[i]=a[i-1]+b[i];//
        
    for(int i=1;i<=n;i++) cout<<a[i]<<endl;

    return 0;
}

标签:Cow,cow,int,差分,height,vis,数组,Tallest
来源: https://www.cnblogs.com/acm-walker/p/12868416.html