1146 Topological Order (25分) (判断序列是否为拓扑排序)
作者:互联网
1146 Topological Order (25分)
This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:
Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.
Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4
题目大意:给出一组图的有向边,再给出k组序列,让你判断哪些不是拓扑排序
思路:用vector数组存储图,inDegree[]数组记录每个点的入度,arr[]数组存储要检查序列
循环检查arr中的每一个点,如果入度不为0就break,把每个点指向的所有点入度减1
完整代码:
#include <iostream>
#include <vector>
#include <queue>
using namespace std;
vector<int> g[1001];
int n,m,k,arr[1001],inDegree[1001];
int main(){
cin>>n>>m;
int u,v,temp[1001] = {0},res[101];
int cnt = 0;
for(int i = 0;i<m;i++){
scanf("%d%d",&u,&v);
g[u].push_back(v);
temp[v]++;
}
cin>>k;
for(int i = 0;i<k;i++){
//记得每次都要重新赋值inDegree数组
for(int j = 1;j<=n;j++){
inDegree[j] = temp[j];
}
for(int j = 1;j<=n;j++){
scanf("%d",&arr[j]);
}
for(int j = 1;j<=n;j++){
//入度不为0就不能形成拓扑排序
if(inDegree[arr[j]]!=0){
res[cnt++] = i;
break;
}
//该点指向的所有点入度减1
for(int u = 0;u<g[arr[j]].size();u++){
int v = g[arr[j]][u];
inDegree[v]--;
}
}
}
bool flag = false;
for(int i = 0;i<cnt;i++){
if(flag==false){
cout<<res[i];
flag = true;
}
else {
cout<<" "<<res[i];
}
}
return 0;
}
标签:25,1146,int,graph,vertices,Topological,each,line,1001 来源: https://blog.csdn.net/qq_40167974/article/details/104879388