其他分享
首页 > 其他分享> > [PAT乙级] Practise 1012 数字分类

[PAT乙级] Practise 1012 数字分类

作者:互联网

PAT (Basic Level) Practice (中文)1012

1012 数字分类

给定一系列正整数,请按要求对数字进行分类,并输出以下 5 个数字:

输入格式:

每个输入包含 1 个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N,随后给出 N 个不超过 1000 的待分类的正整数。数字间以空格分隔。

输出格式:

对给定的 N 个正整数,按题目要求计算 A1~A5 并在一行中顺序输出。数字间以空格分隔,但行末不得有多余空格。

若其中某一类数字不存在,则在相应位置输出 N

输入样例 1:

13 1 2 3 4 5 6 7 8 9 10 20 16 18

输出样例 1:

30 11 2 9.7 9

输入样例 2:

8 1 2 4 5 6 7 9 16

输出样例 2:

N 11 2 N 9

思路:

由题意可知:

注意:

在求 put[1] 的和时,会有求和结果为也0的情况,注意判断。

代码:

#include <iostream>
#include <map>
using namespace std;

int main() {
    double put[5] = { 0 };
    int na2 = 1, fa2 = 0;
    int va3 = 0, now, N;
    cin >> N;
    for (int i = 0; i < N;i++) {
        cin >> now;
        if (now % 5 == 0 && now % 2 == 0) {
            put[0] += now;
        }
        if (now % 5 == 1) {
            put[1] = put[1] + now * na2;
            na2 *= -1;
            fa2++;
        }
        if (now % 5 == 2) {
            put[2]++;
        }
        if (now % 5 == 3) {
            put[3] += now;
            va3++;
        }
        if (now % 5 == 4 && now > put[4]) {
            put[4] = now;
        }
        if (cin.get() == '\n')
            break;
    }
    if (put[3] != 0) put[3] /= va3;
    if (put[0] == 0) cout << "N" << " ";
    else if (put[0] > 0) cout << put[0] << " ";

    if (fa2 == 0 ) cout << "N" << " ";
    else if (fa2 > 0) cout << put[1] << " ";

    if (put[2] == 0) cout << "N" << " ";
    else if (put[2] > 0) cout << put[2] << " ";

    if (put[3] == 0.0) cout << "N" << " ";
    else if (put[3] > 0.0)
        printf("%.1f ", put[3]);

    if (put[4] == 0) cout << "N";
    else if (put[4] > 0) cout << put[4];
    return 0;
}

标签:除后,Practise,PAT,数字,样例,put,now,1012,cout
来源: https://www.cnblogs.com/eisuto/p/12490911.html