其他分享
首页 > 其他分享> > Humble Numbers

Humble Numbers

作者:互联网

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying “The nth humble number is number.”. Depending on the value of n, the correct suffix “st”, “nd”, “rd”, or “th” for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

思路

首先这是一道可以暴力也可以dp的题
dp的思路就是 每次我们n的值就是上一个n中*2 *3 *5 *7中最小的那个数
然后根据题目的输入输出可以知道这个数值最后很大 得开longlong
而且得预处理
dp核心代码

long long f(){
	long long t=min(min(2*dp[a],3*dp[b]),min(5*dp[c],7*dp[d]));
	if(t==2*dp[a])a++;
	if(t==3*dp[b])b++;
	if(t==5*dp[c])c++;
	if(t==7*dp[d])d++;
	return t;
}

代码

#include<bits/stdc++.h>
using namespace std;
long long dp[6000];
int a=1,b=1,c=1,d=1;
long long f(){
	long long t=min(min(2*dp[a],3*dp[b]),min(5*dp[c],7*dp[d]));
	if(t==2*dp[a])a++;
	if(t==3*dp[b])b++;
	if(t==5*dp[c])c++;
	if(t==7*dp[d])d++;
	return t;
}
int main(){
	dp[1]=1;
	for(int i=2;i<=5842;i++){
		dp[i]=f();
	}
	int n;
	while(cin>>n&&n>0){
		cout<<"The "<<n;
        if(n%10==1&&n%100!=11)
            cout<<"st";
        else if(n%10== 2&&n%100!=12)
            cout<<"nd";
        else if(n%10==3&&n%100!=13)
            cout<<"rd";
        else
           	cout<<"th";
        cout<<" humble number is "<<dp[n]<<"."<<endl;
	}
	return 0;
}

标签:Humble,min,++,humble,number,long,Numbers,dp
来源: https://blog.csdn.net/Xigua_____/article/details/104804011