其他分享
首页 > 其他分享> > hdu 2090 算菜价

hdu 2090 算菜价

作者:互联网

Problem Description

妈妈每天都要出去买菜,但是回来后,兜里的钱也懒得数一数,到底花了多少钱真是一笔糊涂帐。现在好了,作为好儿子(女儿)的你可以给她用程序算一下了,呵呵。

Input

输入含有一些数据组,每组数据包括菜种(字串),数量(计量单位不论,一律为double型数)和单价(double型数,表示人民币元数),因此,每组数据的菜价就是数量乘上单价啊。菜种、数量和单价之间都有空格隔开的。

Output

支付菜价的时候,由于最小支付单位是角,所以总是在支付的时候采用四舍五入的方法把分头去掉。最后,请输出一个精度为角的菜价总量。

Sample Input

青菜 1 2 罗卜 2 1.5 鸡腿 2 4.2

Sample Output

13.4
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <cmath>
#include <map>

using namespace std;
typedef long long ll;

const double inf=1e20;
const int maxn=100+10;
const int mod=1e9+7;

int main(){
    char an[100];
    double a,b,c=0;
    while(scanf("%s %lf %lf",&an,&a,&b)!=EOF){
        c=a*b+c;
    }
    printf("%.1lf\n",c);
    return 0;
}

 

标签:菜价,hdu,菜种,const,int,double,2090,include
来源: https://www.cnblogs.com/wz-archer/p/12446735.html