其他分享
首页 > 其他分享> > 贪心思想:洛谷 P1223 排队接水

贪心思想:洛谷 P1223 排队接水

作者:互联网

题目来自:点击这里
题目如下:
有 n 个人在一个水龙头前排队接水,假如每个人接水的时间为 T i,请编程找出这 n 个人排队的一种顺序,使得 n 个人的平均等待时间最小。
输入格式
第一行为一个整数 n。
第二行 n个整数,第 i 个整数 T i​ 表示第 i个人的等待时间 T i 。
输出格式
输出文件有两行,第一行为一种平均时间最短的排队顺序;第二行为这种排列方案下的平均等待时间(输出结果精确到小数点后两位)。

输入样例

10 
56 12 1 99 1000 234 33 55 99 812

输出样例

3 2 7 8 1 4 9 6 10 5
291.90
#include<cstdio>//停一下,接水问题这不是小学5,6年级学过的吗!!!非常简单的,不信看下面一片文章*/
/*https://baijiahao.baidu.com/s?id=1625812134445706025&wfr=spider&for=pc*/
#include<stack>
#include<iostream>
#include<queue>
#include<algorithm>
#include<iterator>
using namespace std;
struct jia{
	int a,b;
}nai[1000+6];
bool cmp(struct jia p,struct jia q){
	return p.a<q.a;
}//排序函数
int main(){
	int n,m;
	long long sum=0;//注意用long long 储存
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d",&nai[i].a);
		nai[i].b=i;
	}
	sort(nai,nai+n,cmp);
	for(int i=0;i<n;i++){
		printf("%d",nai[i].b+1);
		if(i<n-1)
			printf(" ");
		else
			printf("\n");
		sum+=nai[i].a*(n-i-1);
	}
	printf("%.2f",sum*1.0/n);
	return 0;
}
是羽白啊 发布了29 篇原创文章 · 获赞 5 · 访问量 1009 私信 关注

标签:输出,洛谷,struct,jia,排队,等待时间,P1223,include,贪心
来源: https://blog.csdn.net/qq_45695839/article/details/104637018