其他分享
首页 > 其他分享> > 1002 A+B for Polynomials

1002 A+B for Polynomials

作者:互联网

题目链接

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
在这里插入图片描述
where K is the number of nonzero terms in the polynomial,
在这里插入图片描述
are the exponents and coefficients, respectively. It is given that
在这里插入图片描述
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:
3 2 1.5 1 2.9 0 3.2

大致题意
两行分别输入 k ,接下来2*k个数分别表示多项式指数和系数,输出两行多项式总和,指数由大到小,系数为0不需要输出

具体思路
有点类似桶排序的标记原理,将指数作为数组标记,系数累加,下面做法的空间较大,有兴趣的可以用vector进行优化

#include<bits/stdc++.h>
using namespace std;
typedef long long int LLD;
int main()
{
    double N[1005];
    memset(N,0,sizeof(N));
    LLD k;
    scanf("%lld",&k);
    while (k--)
    {
        LLD Ni;
        double An;
        scanf("%lld %lf",&Ni,&An);
        N[Ni]+=An;
    }
    scanf("%lld",&k);
    while (k--)
    {
        LLD Ni;
        double An;
        scanf("%lld %lf",&Ni,&An);
        N[Ni]+=An;
    }
    LLD num=0,MIN=1000;
    for (LLD i=1000; i>=0; i--)
    {
        if (N[i]!=0)
        {
            num++;
            MIN=i;
        }
    }
    printf("%lld",num);
    if (num!=0)
        printf(" ");
    for (LLD i=1000; i>=MIN; i--)
    {
        if (N[i]!=0.0)
        {
            printf("%lld %.1lf",i,N[i]);
            if (i!=MIN)
            {
                printf(" ");
            }
        }

    }
    return 0;
}

白雪黑夜我不停歇 发布了17 篇原创文章 · 获赞 4 · 访问量 4331 私信 关注

标签:Ni,MIN,Polynomials,num,printf,LLD,1002,lld
来源: https://blog.csdn.net/qq_43735840/article/details/104520768