其他分享
首页 > 其他分享> > 1116 Come on! Let's C (20分)

1116 Come on! Let's C (20分)

作者:互联网

"Let's C" is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

Given the final ranklist and a sequence of contestant ID's, you are supposed to tell the corresponding awards.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​4​​), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant's ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID's.

Output Specification:

For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

Sample Input:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

Sample Output:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?
#include<iostream>
#include<unordered_map>
#include<cmath>

using namespace std;
bool is_prime(int num){

    int sqrt_mun = sqrt(num);

    if(num <= 1){
        return false;
    }
    for(int i = 2; i <= sqrt_mun; i++){

        if(num % i == 0){

            return false;
        }

    }
    return true;

}

int main(){
    int n; 
    unordered_map<int, int> un_map;
    bool visit[10001] = {false};
    cin >> n;
    for(int i = 1; i <= n; i++){
        int temp;

        scanf("%d", &temp);
        un_map[temp] = i;

    }
    int k;
    cin >> k;
    for(int i = 0; i < k; i++){ 
        int out_temp;
        scanf("%d", &out_temp);
        if(un_map[out_temp] != 0){
            if(visit[out_temp]){
                printf("%04d: Checked\n", out_temp);
            }else{
                if(un_map[out_temp] == 1){
                    printf("%04d: Mystery Award\n", out_temp);
                }else if(is_prime(un_map[out_temp])){

                    printf("%04d: Minion\n", out_temp);

                }else{

                    printf("%04d: Chocolate\n", out_temp);
                }


            }
        }else
        {
            printf("%04d: Are you kidding?\n", out_temp);
        }
        



        visit[out_temp] = true;


    }



    return 0;
}

 

zbchenchanghao 发布了55 篇原创文章 · 获赞 0 · 访问量 739 私信 关注

标签:20,temp,04d,else,Let,8888,Come,ID,out
来源: https://blog.csdn.net/zbchenchanghao/article/details/104125193