其他分享
首页 > 其他分享> > PAT甲级 1002 A+B for Polynomials

PAT甲级 1002 A+B for Polynomials

作者:互联网

PAT甲级 1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

KKK N1N_1N1​ aN1a_{N_1}aN1​​ N2N_2N2​ aN2a_{N_2}aN2​​ ......... NKN_KNK​ aNKa_{N_K}aNK​​
​​
where K is the number of nonzero terms in the polynomial, NiN_​iN​​i and aNia_{​N​_i}a​N​i​​
​​
​​ (i=1,2,,K)(i=1,2,⋯,K)(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1K100NK<<N2<N11000.1≤K≤10,0≤N​_K<⋯<N_2<N_1≤1000.1≤K≤10,0≤N​K​<⋯<N2​<N1​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

多项式的A+B,符合PAT的套路,坑多,注意相加也会出现0的情况,直接暴力算即可,AC代码如下:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e3+5;
double p[maxn]={0.0};
int k, n, ans = 0;
double a;
int main() {
    scanf("%d", &k);
    for(int i = 0; i < k; i++) {
        scanf("%d %lf", &n, &a);
        p[n] += a;
    }
    scanf("%d", &k);
    for(int i = 0; i < k; i++) {
        scanf("%d %lf", &n, &a);
        p[n] += a;
    }
    for(int i = 0; i < maxn; i++) {
        if(p[i] != 0) {
            ans++;
        }
    }
    printf("%d", ans);
    for(int i = maxn; i >= 0; i--) {
        if(p[i] != 0) {
            printf(" %d %.1f", i, p[i]);
        }
    }
    return 0;
}
旺 崽 发布了248 篇原创文章 · 获赞 13 · 访问量 2万+ 私信 关注

标签:PAT,int,scanf,Polynomials,++,maxn,each,1002
来源: https://blog.csdn.net/qq_43765333/article/details/104116791