其他分享
首页 > 其他分享> > Asteroids【最小点覆盖】

Asteroids【最小点覆盖】

作者:互联网

Asteroids SSL 1341

Description–

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid . The grid contains K asteroids, which are conveniently located at the lattice points of the grid.
Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
题目给出一个矩阵,上面有敌人,每个子弹可以打出一横行或者一竖行,问最少用多少子弹消灭都有敌人,如:
X.X
.X.
.X.


Input–

Output–


Sample Input–

3 4
1 1
1 3
2 2
3 2

Sample Output–

2

说明–

1 <= N <= 500
1 <= K <= 10,000


代码–

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

int n, k, x, y, ans, l[105], f[105][105];
bool pd[105];

bool find(int o)
{
	for (int i = 1; i <= n; ++i)
	  if (f[o][i] && !pd[i])
	  {
	  	  pd[i] = 1;
	  	  int e = l[i];
	  	  l[i] = o;
          if (!e || find(e)) return 1;
          l[i] = e;
	  }
    return 0;
}

int main()
{
	scanf("%d%d", &n, &k);
	for (int i = 1; i <= k; ++i)
	{
		scanf("%d%d", &x, &y);
		f[x][y] = 1;
	}
	for (int i = 1; i <= n; ++i)
	{
		memset(pd, 0, sizeof(pd));
		if (find(i)) ans++;
	}
	printf("%d", ans);
	
	return 0;
}
MYRER 发布了123 篇原创文章 · 获赞 39 · 访问量 5572 私信 关注

标签:Asteroids,覆盖,asteroids,最小,Output,grid,Input,Bessie,105
来源: https://blog.csdn.net/qq_43654542/article/details/104021123