其他分享
首页 > 其他分享> > 问题 D: MooBuzz----二分+容斥

问题 D: MooBuzz----二分+容斥

作者:互联网

题目描述
Farmer John’s cows have recently become fans of playing a simple number game called “FizzBuzz”. The rules of the game are simple: standing in a circle, the cows sequentially count upward from one, each cow saying a single number when it is her turn. If a cow ever reaches a multiple of 3, however, she should say “Fizz” instead of that number. If a cow reaches a multiple of 5, she should say “Buzz” instead of that number. If a cow reaches a multiple of 15, she should say “FizzBuzz” instead of that number. A transcript of the first part of a game is therefore:
1, 2, Fizz, 4, Buzz, Fizz, 7, 8, Fizz, Buzz, 11, Fizz, 13, 14, FizzBuzz, 16

Having a slightly more limited vocabulary, the version of FizzBuzz played by the cows involves saying “Moo” instead of Fizz, Buzz, and FizzBuzz. The beginning of the cow version of the game is therefore

1, 2, Moo, 4, Moo, Moo, 7, 8, Moo, Moo, 11, Moo, 13, 14, Moo, 16

Given N (1≤N≤109), please determine the Nth number spoken in this game.

SCORING
Test cases 2-5 satisfy N≤106.
输入
The input consists of a single integer, N.
输出
Please print out the Nth number spoken during the game.
样例输入 Copy
4
样例输出 Copy
7
提示
The 4th number spoken is 7. The first 4 numbers spoken are 1, 2, 4, 7, since we skip over any time a cow says “Moo”.

解析:对于第n个数,只要计算第n个数+之前被跳过去的数cnt,就可以得到答案。
cnt 显然等于 n 内 3 的倍数 + 5 的倍数 +15的倍数,但是15 = 3 * 5,所以15不需要重复统计(已经在 3 的倍数中统计过了)。但是我们重复统计了 3 和 5 的公倍数(统计了 2 次),于是我们就要减去同时是 3 的倍数和 5 的倍数 的 个数即可得到cnt。
我们就可以在O(logN)时间内用二分搜索解决此题。


#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const ll N=1e18;
ll  t;
ll check(ll n)
{
	ll a=n/3;
	ll b=n/5;
	ll c=n/15;
	ll cnt=a+b-c;
	return n-cnt>=t;//n-cnt表示符合的数
}
int main()
{
	scanf("%lld",&t);
	ll l=1,r=N;
	while(l<=r)
	{
		ll mid=l+r>>1;
		if(check(mid)) r=mid-1;
		else l=mid+1;
	}
	cout<<l<<endl;
 } 
AKone123456 发布了263 篇原创文章 · 获赞 5 · 访问量 3245 私信 关注

标签:二分,cnt,ll,容斥,number,game,MooBuzz,Moo,Fizz
来源: https://blog.csdn.net/qq_43690454/article/details/103987815