其他分享
首页 > 其他分享> > A1002. A+B for Polynomials

A1002. A+B for Polynomials

作者:互联网

题目描述

  This time, you are supposed to find A+B where A and B are two polynomials

输入格式

  Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK , where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,...,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤Nk<...<N2<N≤1000

输出格式

  For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line.

Please be accurate to 1 decimal place.

输入样例

2 1 2.4 0 3.2

2 2 1.5 1 0.5

输出样例

3 2 1.5 1 2.9 0 3.2

题意

样例解释

#include <bits/stdc++.h>
const int max_n = 1111;
double p[max_n] = {};
int main(int argc, char *argv[]) {
    int k, n, count = 0;
    double a;
    scanf("%d", &k);
    for(int i = 0; i < k; i++){
        scanf("%d %1f", &n, &a);
        p[n] += a;
    }
    scanf("%d", &k);
    for(int i = 0; i < k; i++){
        scanf("%d %1f", &n, &a);
        p[n] += a;
    }
    for(int i = 0; i < max_n; i++){
        if(p[i] != 0){
            count++;
        }
    }
    printf("%d", count);
    for(int i = max_n - 1; i >= 0; i--){
        if(p[i] != 0){
            printf( "%d %.1f", i, p[i]);
        }
    }
    return 0;    
}

标签:int,多项式,scanf,++,Polynomials,A1002,3.2,2.4
来源: https://www.cnblogs.com/YC-L/p/12187244.html