poj 1113 wall
作者:互联网
Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall.
Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements.
The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.Input
The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.
Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.Output
Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.
Sample Input
9 100 200 400 300 400 300 300 400 300 400 400 500 400 500 200 350 200 200 200Sample Output
1628Hint
结果四舍五入就可以了
题目大意:给你一个城堡的n个点,现在要你建个墙使得这些墙距离这个城堡的距离都不超过一个距离
思路:凸包,凸包求多边形的周长,然后加上四个半圆周即为要求长度。为什么要加四个半圆周的长度?
以题目为例,我们在围成这个城堡后可以平行,然后加上四个圆周长即可如下图
代码:
/*
题目大意:现在给你n个点,让你使用这些点构成一个面积尽可能大的多边形,注意这些点不是会被全部使用
思路:凸包,直接求面积即可
*/
#include<set>
#include<map>
#include<ctime>
#include<stack>
#include<queue>
#include<cmath>
#include<string>
#include<vector>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f
#define bug printf("bug\n")
const int maxn=1e6+10;
const double pi=acos(-1.0);
const double esp=1e-6;
const int N=2e2+10;
struct point
{
int x,y;
};
struct line
{
point st,ed;
double k,b;
};
int sign(double x)
{
if(fabs(x)<esp)
return 0;
return x>0?1:-1;
}
double getk(line l)
{
if(l.st.x==l.ed.x)///斜率不存在
return inf;
return (l.ed.y-l.st.y)/(l.ed.x-l.st.x);
}
double getb(line l)
{
return l.ed.y-l.k*l.ed.x;
}
double dis(point a,point b)
{
return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int cmult(point a,point b,point c)///叉积
{
return (b.x-a.x)*(c.y-a.y)-(c.x-a.x)*(b.y-a.y);
}
point p[maxn];
int cmp(point a,point b)
{
int ju=cmult(p[0],a,b);
if(ju>0)
return 1;
else if(ju==0&&dis(a,p[0])<dis(b,p[0]))
return 1;
return 0;
}
int n;
int Stack[maxn],top;
void tb()
{
point p0;
int k=0;
p0=p[0];
for(int i=1; i<n; i++)
{
if(p0.y>p[i].y||(p0.y==p[i].y&&p0.x==p[i].x))
{
p0=p[i];
k=i;
}
}
swap(p[k],p[0]);
sort(p+1,p+n,cmp);
if(n==1)
{
top=0;
Stack[0]=0;
return ;
}
if(n==2)
{
top=1;
Stack[0]=0;
Stack[1]=1;
return;
}
if(n>2)
{
top=1;
for(int i=0; i<=1; i++)
Stack[i]=i;
for(int i=2; i<n; i++)
{
while(top>0&&cmult(p[Stack[top-1]],p[Stack[top]],p[i])<=0)
top--;
top++;
Stack[top]=i;
}
}
}
int main()
{
int l;
while(scanf("%d%d",&n,&l)!=EOF)
{
top=0;
for(int i=0;i<n;i++)
scanf("%d%d",&p[i].x,&p[i].y);
tb();
double ans=0;
for(int i=0;i<top;i++)
{
ans+=dis(p[Stack[i]],p[Stack[i+1]]);
}
ans+=dis(p[Stack[0]],p[Stack[top]]);
ans+=2*pi*l;
printf("%.0f\n",ans);
}
return 0;
}
标签:King,return,point,wall,1113,poj,castle,include 来源: https://blog.csdn.net/lee371042/article/details/101421850