其他分享
首页 > 其他分享> > HDU1790

HDU1790

作者:互联网

Description:

给你n个点,m条无向边,每条边都有长度d和花费p,给你起点s终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。

Input

输入n,m,点的编号是1~n,然后是m行,每行4个数 a,b,d,p,表示a和b之间有一条边,且其长度为d,花费为p。最后一行是两个数 s,t;起点s,终点。n和m为0时输入结束。
(1<n<=1000, 0<m<100000, s != t)

Output

输出 一行有两个数, 最短距离及其花费。

Sample Input

3 2
1 2 5 6
2 3 4 5
1 3
0 0

Sample Output

9 11

有重边的情况,所以在输入的时候需要注意如果两个点路径有多条相同的取花费小的,否则取路径最短的那条不用管花费;也就是说,不管在输入或者输出的时候都要以路径为前提,一定要的是最短的,如果最短的有多条再取花费小的;

AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stdlib.h>
#include<queue>
#include<set>
#include<map>
#include<iomanip>
#include<math.h>
using namespace std;
typedef long long ll;
typedef double ld;
const int INF=0x3f3f3f3f;
using namespace std;
int i,j,k;
int n,m,t;
int x,y;
int u,v,w;
int ans,res,cnt,temp,sum;
#define N 1050
int map1[N][N];//记录距离
int map2[N][N]; //记录路的花销
int dist[N],cost[N];//最短路径集,花销集
int s1[N];
int n,s,t;//点个数,起始点,终点

void dijstra()
{
    int i,j;
    int minn,u;
    for(i=0; i<n; i++)
    {
        if(map1[s][i]<INF)
        {
            dist[i]=map1[s][i];
            cost[i]=map2[s][i];
        }
    }
    dist[s]=0;
    cost[s]=0;
    s1[s]=1;
    for(i=1; i<n; i++)
    {
        minn=INF;
        for(j=0; j<n; j++)
        {
            if((minn>dist[j])&&(s1[j]==0))
            {
                u=j;
                minn=dist[j];
            }
        }
        s1[u]=1;
        for(j=0; j<n; j++)
        {
            if(dist[u]+map1[u][j]<dist[j])
            {
                dist[j]=dist[u]+map1[u][j];
                cost[j]=cost[u]+map2[u][j];
            }
            else if(dist[u]+map1[u][j]==dist[j])
            {
                if(cost[u]+map2[u][j]<cost[j])//距离相同则刷新花销
                {
                    cost[j]=cost[u]+map2[u][j];
                }
            }
        }
    }
}

int main()
{
    int i,j,m,x,y,c,lon;
    while(~scanf("%d%d",&n,&m))
    {
        if(m==0&&n==0)
        {
            return 0;
        }
        for(i=0; i<n; i++)
        {
            for(j=0; j<n; j++)
            {
                if(i==j)
                {
                    map1[i][j]=0;
                    map2[i][j]=0;
                }
                else
                {
                    map1[i][j]=INF;
                    map2[i][j]=INF;
                }
            }
            s1[i]=0;
            dist[i]=INF;
            cost[i]=INF;
        }
        for(i=0; i<m; i++)
        {
            scanf("%d%d%d%d",&x,&y,&lon,&c);
            x--;
            y--;
            if(map1[x][y]>lon)
            {
                map1[x][y]=lon;
                map1[y][x]=lon;
                map2[x][y]=c;
                map2[y][x]=c;
            }
            else if(map1[x][y]==lon)
            {
                if(map2[x][y]>c)
                {
                    map1[x][y]=lon;
                    map1[y][x]=lon;
                    map2[x][y]=c;
                    map2[y][x]=c;
                }
            }
        }
        scanf("%d%d",&s,&t);
        s--;
        t--;
        dijstra();
        printf("%d %d\n",dist[t],cost[t]);
    }
    return 0;
}

 

标签:int,lon,map2,花费,map1,HDU1790,include
来源: https://blog.csdn.net/qq_43627087/article/details/100779318