其他分享
首页 > 其他分享> > [PAT]1126 Eulerian Path (25 分)(样例3答案错误原因)

[PAT]1126 Eulerian Path (25 分)(样例3答案错误原因)

作者:互联网

一、题意

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either EulerianSemi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:

2 4 4 4 4 4 2
Eulerian

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian

二、题解

题目大意是,给出一个无向图,先输出各个点的度,然后再判断这个图是否是欧拉图。如果含有欧拉路,输出"Semi-Eulerian
",含有欧拉回路输出"Eulerian",如果既没有欧拉回路又没有欧拉回路那么输出"Non-Eulerian"。

根据离散数学中的知识已知:一个连通图,如果有0个或者2个点的度数为奇数,那么一定含有欧拉路。如果有0个点度数为奇数,那么一定含有欧拉回路。

因此可以根据所有点的度数来判断图是否含有欧拉路、欧拉回路。

同时需要注意要判断图是否是连通图,样例3答案错误就是因为没有判断图是否是连通图。(在代码中使用dfs遍历图,如果遍历的点的个数不等于点的总数,那么说明至少有两个连通分支,图不是连通图,既然连连通图都不算,那么久肯定不含欧拉路和欧拉回路了)。

AC代码:

#include <bits/stdc++.h>

using namespace std;

struct node {
    vector<int > edges;

};

vector<node> nodes;
int cnt = 0;
vector<bool> vis;
void dfs(int id) {
    vis[id] = true;
    cnt ++;
    for(int i=0; i<nodes[id].edges.size(); i++) {
        if(vis[nodes[id].edges[i]] == false) {
            dfs(nodes[id].edges[i]);
        } else {
            continue;
        }
    }
}


int main() {
    int n,m;

    cin>>n>>m;

    nodes.reserve(n+1);
    vis.resize(n+1);
    fill(vis.begin(), vis.end(), false);
    for(int i=0; i<m; i++) {
        int a,b;
        cin>>a>>b;
        nodes[a].edges.push_back(b);
        nodes[b].edges.push_back(a);
    }

    int cntodd = 0;


    for(int i=1; i<=n; i++) {
        if(nodes[i].edges.size()%2 == 1) {
            cntodd ++;
        }
    }
    dfs(1);
    for(int i=1; i<n; i++) {
        cout<<nodes[i].edges.size()<<" ";
    }
    cout<<nodes[n].edges.size()<<endl;

    if(cnt != n) {
        cout<<"Non-Eulerian"<<endl;
        return 0;
    }

    if(cntodd == 0) {
        cout<<"Eulerian"<<endl;
        return 0;
    }
    if(cntodd == 2) {
        cout<<"Semi-Eulerian"<<endl;
        return 0;
    }
    cout<<"Non-Eulerian"<<endl;

    return 0;
}

 

标签:25,PAT,int,graph,样例,Sample,vis,Eulerian,欧拉
来源: https://blog.csdn.net/Strengthennn/article/details/100170737