其他分享
首页 > 其他分享> > HDU - 5115 Dire Wolf(区间dp)

HDU - 5115 Dire Wolf(区间dp)

作者:互联网

Dire wolves, also known as Dark wolves, are extraordinarily large and powerful wolves. Many, if not all, Dire Wolves appear to originate from Draenor.
Dire wolves look like normal wolves, but these creatures are of nearly twice the size. These powerful beasts, 8 - 9 feet long and weighing 600 - 800 pounds, are the most well-known orc mounts. As tall as a man, these great wolves have long tusked jaws that look like they could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore.
Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs, surrounding and flanking a foe when they can.
— Wowpedia, Your wiki guide to the World of Warcra

Matt, an adventurer from the Eastern Kingdoms, meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive.

Once Matt defeats a dire wolf, he will take some damage which is equal to the wolf’s current attack. As gregarious beasts, each dire wolf i can increase its adjacent wolves’ attack by b i. Thus, each dire wolf i’s current attack consists of two parts, its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated, its adjacent wolves will no longer get extra attack from it. However, these two wolves (if exist) will become adjacent to each other now.

For example, suppose there are 3 dire wolves standing in a row, whose basic attacks ai are (3, 5, 7), respectively. The extra attacks b i they can provide are (8, 2, 0). Thus, the current attacks of them are (5, 13, 9). If Matt defeats the second wolf first, he will get 13 points of damage and the alive wolves’ current attacks become (3, 15).

As an alert and resourceful adventurer, Matt can decide the order of the dire wolves he defeats. Therefore, he wants to know the least damage he has to take to defeat all the wolves.
Input
The first line contains only one integer T , which indicates the number of test cases. For each test case, the first line contains only one integer N (2 ≤ N ≤ 200).

The second line contains N integers a i (0 ≤ a i ≤ 100000), denoting the basic attack of each dire wolf.

The third line contains N integers b i (0 ≤ b i ≤ 50000), denoting the extra attack each dire wolf can provide.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the least damage Matt needs to take.
Sample Input
2
3
3 5 7
8 2 0
10
1 3 5 7 9 2 4 6 8 10
9 4 1 2 1 2 1 4 5 1
Sample Output
Case #1: 17
Case #2: 74

题意:有n头狼排成一排,每只狼两个属性,攻击力和加成值,狼的实际攻击力等于自身攻击力加相邻狼的加成值,被杀死之后的狼对相邻的狼的攻击力的加成会被取消,同时,原先与 被杀死的狼相邻的两头狼会变成相邻的狼。问杀死所有狼受到的伤害值最小是多少。

思路:区间dp,dp[i][j]表示将区间i-j内的狼全部杀死受到的最小伤害
枚举中间点k(区间内最后一个杀死的狼),i<=k<=j

转移方程为 dp[i][j]=min(dp[i][j], dp[i][k-1]+dp[k+1][j]+a[k]+b[i-1]+b[j+1])

=>既然k是区间内最后一个杀死的,那么i-1和j+1就是它的相邻狼,要加上它们的攻击加成

循环写法:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define inf 0x3f3f3f3f
typedef long long ll;
const int N = 205;
ll dp[N][N],a[N],b[N];
int main()
{
	int t,cas=1;
	cin>>t;
	while(t--)
	{
		int n;
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
			scanf("%lld",&a[i]);
		for(int i=1;i<=n;i++)
			scanf("%lld",&b[i]);
		for(int i=1;i<=n;i++)
			for(int j=i;j<=n;j++)
				dp[i][j]=inf;
		for(int len=0;len<=n;len++)
			for(int i=1;i+len<=n;i++)
			{
				int j=i+len;
				for(int k=i;k<=j;k++)
					dp[i][j]=min(dp[i][j],dp[i][k-1]+dp[k+1][j]+a[k]+b[i-1]+b[j+1]);
			}
		printf("Case #%d: ",cas++);
		cout<<dp[1][n]<<endl;
	}
	return 0;
 } 


记忆化搜索写法:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define inf 0x3f3f3f3f
typedef long long ll;
const int N = 210;
ll dp[N][N],a[N],b[N];
int n;
ll dfs(int l,int r)
{
	if(l<1||r>n||l>r)
		return 0;
	if(dp[l][r]&&dp[l][r]!=inf)
		return dp[l][r];
	for(int i=l;i<=r;i++)
	{
		dp[l][r]=min(dfs(l,i-1)+dfs(i+1,r)+a[i]+b[l-1]+b[r+1],dp[l][r]);
	}
	return dp[l][r];
}
int main()
{
	int t,cas=1;
	cin>>t;
	while(t--)
	{
		scanf("%d",&n);
		memset(dp,0,sizeof dp);
		for(int i=1;i<=n;i++)
			scanf("%lld",&a[i]);
		for(int i=1;i<=n;i++)
			scanf("%lld",&b[i]);
		for(int i=1;i<=n;i++)
			for(int j=i;j<=n;j++)
				dp[i][j]=inf;
		printf("Case #%d: %lld\n",cas++,dfs(1,n));
	}
	return 0;
 } 

标签:5115,HDU,int,attack,Wolf,dire,wolf,wolves,dp
来源: https://blog.csdn.net/weixin_43693379/article/details/100117054