其他分享
首页 > 其他分享> > POJ 2398 计算几何之Toy Storage

POJ 2398 计算几何之Toy Storage

作者:互联网

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza’s parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:
We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input
The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.
A line consisting of a single 0 terminates the input.

Output
For each box, first provide a header stating “Box” on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input
4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output
Box
2: 5
Box
1: 4
2: 1

题目2318的进阶题,
给一个矩形,用N条线段将矩形分区域,撒一堆点,找每个区域的点个数有多少。
这次给的线段没有按照顺序,所以要对线段排序。
输出也有变化,输出的是 点的个数为x的区域个数有多少个
Box
点的个数x:拥有x个点的区域个数
当然x不能等于0

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#define ll long long
#define inf 0x3f3f3f3f
#define N 5010
using namespace std;
struct Point{
    int x,y;
};
struct Line{
    Point a,b;
}line[N];
int cnt[N],ans[N];
bool cmp(Line l,Line r){
    return l.a.x<r.a.x;
}
int Multi(Point a,Point b,Point c){
    return (a.x-c.x)*(b.y-c.y)-(b.x-c.x)*(a.y-c.y);
}
void BS(Point a,int n){
    int l=0,r=n-1,mid;
    while(l<r){
        mid=(l+r)>>1;
        if(Multi(a,line[mid].a,line[mid].b)>0)l=mid+1;
        else r=mid;
    }
    if(Multi(a,line[l].a,line[l].b)<0)cnt[l]++;
    else cnt[l+1]++;
}
int main(){
    int n,m,x1,y1,x2,y2;
    int t1,t2;
    Point a;
    while(scanf("%d",&n)!=EOF&&n){
        scanf("%d %d %d %d %d",&m,&x1,&y1,&x2,&y2);
        for(int i=0;i<n;i++){
            scanf("%d %d",&t1,&t2);
            line[i].a.x=t1;
            line[i].a.y=y1;
            line[i].b.x=t2;
            line[i].b.y=y2;
        }
        sort(line,line+n,cmp);
        memset(cnt,0,sizeof(cnt));
        memset(ans,0,sizeof(ans));
        for(int i=0;i<m;i++){
            scanf("%d %d",&a.x,&a.y);
            BS(a,n);
        }
        for(int i=0;i<=n;i++){
            ans[cnt[i]]++;
        }
        printf ("Box\n");
        for(int i=1;i<=m;i++){
            if(ans[i]>0)printf("%d: %d\n",i,ans[i]);
            m-=i*cnt[i];
        }
    }
    return 0;
}

标签:box,10,Toy,Reza,Storage,POJ,toys,line,include
来源: https://blog.csdn.net/weixin_44705665/article/details/100023036