其他分享
首页 > 其他分享> > poj 1276 Cash Machine

poj 1276 Cash Machine

作者:互联网

Cash Machine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 45189   Accepted: 16490

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 
N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 
means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 
Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 
Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 
cash N n1 D1 n2 D2 ... nN DN 
where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350 
633 4  500 30  6 100  1 5  0 1 
735 0 
0 3  10 100  10 50  10 10

Sample Output

735 
630 
0 
0
题意:现金cash,n种钱币,每种为张,价值为,求这n种钱币组合后小于等于cash的最大值。

题解:
多重背包。二进制优化。

代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
const int maxn=1005;
int num[maxn],w[maxn],dp[maxn*maxn],W;
void zero_onepack(int w);
void compelete_pack(int w);
int main()
{
   int i,n;
   while(~scanf("%d%d",&W,&n))
   {
    {
      fill(dp,dp+maxn*maxn,0);
    }
    for(i=1;i<=n;i++) scanf("%d%d",&num[i],&w[i]);
    for(i=1;i<=n;i++)
    {
      if(num[i]*w[i]>=W) compelete_pack(w[i]);
      else
      {
        int k=1;
        while(k<=num[i])
        {
          zero_onepack(k*w[i]);
          num[i]-=k;
          k<<=1;
        }
        zero_onepack(num[i]*w[i]);
      }
    }
    printf("%d\n",dp[W]);
   }

   return 0;
}
void zero_onepack(int w)
{
  for(int j=W;j>=w;j--)
   dp[j]=max(dp[j],dp[j-w]+w);
}
void compelete_pack(int w)
{
  for(int j=w;j<=W;j++)
   dp[j]=max(dp[j],dp[j-w]+w);
}

标签:machine,10,int,Cash,cash,Machine,poj,maxn,dp
来源: https://www.cnblogs.com/VividBinGo/p/11354320.html