其他分享
首页 > 其他分享> > Heavy Transportation

Heavy Transportation

作者:互联网

Description

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input

1
3 3
1 2 3
1 3 4
2 3 5
Sample Output

Scenario #1:
4

这道题目要求的是从1到N各个路径最小值的最大值。最短路的变形,好长时间没写最短路都快忘了。本来感觉dfs也可以写,不过数据太大了,感觉会爆。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[1005][1005],m,n,b[1005];
int inf=1e9;
void djk(){
	int i,j,f;
	int v[1005]={0};
	for(i=1;i<=n;i++)
		b[i]=a[1][i];
	v[1]=1;
	b[1]=0;
	while(1){
		b[0]=0;
		for(i=1;i<=n;i++){
			if(!v[i]&&b[i]>b[0]){
				b[0]=b[i];
				f=i;
			}
		}
		v[f]=1;
		if(!b[0]) break;
		for(i=1;i<=n;i++){
			if(!v[i]&&b[i]<min(a[f][i],b[f])){
				b[i]=min(a[f][i],b[f]);
			}
		}
	}
}
int main()
{
	int i,j,t,x,y,z,c=1;
	scanf("%d",&t);
	while(t--){
		scanf("%d %d",&n,&m);
		memset(a,0,sizeof(a));
		while(m--){
			scanf("%d %d %d",&x,&y,&z);
			a[x][y]=a[y][x]=z;
		}
		djk();
		printf("Scenario #%d:\n%d\n\n",c++,b[n]);
	}
    return 0;
}  

在家真的好烦,人多了不仅写代码不想写,啥都不想干。最近想了好多事,越想越丧。我真的好不甘心我是这样的,我能改变多少?

标签:Heavy,customer,Transportation,weight,city,streets,place,1005
来源: https://blog.csdn.net/qq_20087731/article/details/99058455