其他分享
首页 > 其他分享> > PAT甲级1071 Speech Patterns (25 分)

PAT甲级1071 Speech Patterns (25 分)

作者:互联网

1071 Speech Patterns (25 )

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5

      题目大意:

         给出一长串字符串,用回车符作为结尾,输出常用的词语及其次数。

 

思路:

         由于要按照字典序大小输出(如果出现的次数相同的话),所以用map类型进行存储,那么在遍历时自然的会找到第一个字典序最小的最多次数的词语。

         用getline整行录入,进行词语摘录时,用isalnum,进行判断, 如果是则让他加到一个临时的string 中, 直到遇到了分隔符。需要特别处理当后面是回车时,也要进行处理(因为回车符是不会存储进来的,所以如果到了最后,需要特判一次。)

         需要优先处理掉其中的大写字母,用tolower函数。

         需要特别注意到是当t长度为0时也会被存储进map的。

 

参考代码:

 

#include<map>
#include<cctype>
#include<iostream>
using namespace std;
string s, t;
map<string, int> mp;
int main(){
	getline(cin, s);
	for(int i = 0; i < s.size(); ++i){
		if(isalnum(s[i])){
			s[i] = tolower(s[i]);
			t += s[i];
		}
		if(!isalnum(s[i]) || i == s.size() - 1){
			if(t.size() != 0)	mp[t]++;
			t = "";
		}
	}
	int maxn = 0;
	for(auto it = mp.begin(); it != mp.end(); ++it)
		if(it->second > maxn){
			t = it->first;
			maxn = it->second;
		}
	printf("%s %d", t.c_str(), maxn);
	return 0;
}

代码参考:https://blog.csdn.net/liuchuo/article/details/52225584

标签:case,25,PAT,word,1071,maxn,mp,text,input
来源: https://blog.csdn.net/qq_42306885/article/details/98785351