1160:倒序数
作者:互联网
1160:倒序数
时间限制: 1000 ms 内存限制: 65536 KB
提交数: 8425 通过数: 6055
【题目描述】
输入一个非负整数,输出这个数的倒序数。例如输入123,输出321。
【输入】
输入一个非负整数(保证个位不为零)。
【输出】
输出倒序的数。
【输入样例】
123
【输出样例】
321
【代码】
#include<iostream>
using namespace std;
void calculate(int n);
int main()
{
int n;
cin>>n;//输入n的值
calculate(n);//调用函数计算并输出n的倒序数
cout<<endl;
return 0;
}
void calculate(int n)
{
cout<<n%10;//输出n的最后一位
if(n>=10) calculate(n/10);//判断是否到达递归边界x<10
}
标签:输出,1160,calculate,int,输入,序数 来源: https://blog.csdn.net/Obey_bey_an/article/details/98775851