其他分享
首页 > 其他分享> > hdu2087——kmp经典变形题(求不可重叠模式串出现次数)

hdu2087——kmp经典变形题(求不可重叠模式串出现次数)

作者:互联网

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2087

一块花布条,里面有些图案,另有一块直接可用的小饰条,里面也有一些图案。对于给定的花布条和小饰条,计算一下能从花布条中尽可能剪出几块小饰条来呢?

Input

输入中含有一些数据,分别是成对出现的花布条和小饰条,其布条都是用可见ASCII字符表示的,可见的ASCII字符有多少个,布条的花纹也有多少种花样。花纹条和小饰条不会超过1000个字符长。如果遇见#字符,则不再进行工作。

Output

输出能从花纹布中剪出的最多小饰条个数,如果一块都没有,那就老老实实输出0,每个结果之间应换行。

Sample Input

abcde a3
aaaaaa  aa
#

Sample Output

0
3

 

这个题和上一个题差不多,可以参考我的这篇博文:https://blog.csdn.net/qq_43472263/article/details/98752602

不过这里模式串在匹配串里是不能重叠的,所以回溯的时候直接回溯到0的位置,其他和上个题基本一样。

#include <iostream>
#include<cstring>
using namespace std;
const int maxn=1e6+5;
inline int read(){
   int s=0,w=1;
   char ch=getchar();
   while(ch<'0'||ch>'9'){if(ch=='-')w=-1;ch=getchar();}
   while(ch>='0'&&ch<='9') s=s*10+ch-'0',ch=getchar();
   return s*w;
}
int cnt;
int nxt[maxn];
char str1[maxn],str2[maxn];
void getnxt(){
	int m=strlen(str1);
	nxt[0]=nxt[1]=0;
	for(int i = 1;i<m;++i){
		int j = nxt[i];
		while(j&&str1[i]!=str1[j]) j=nxt[j];
		nxt[i+1]=str1[i]==str1[j]?j+1:0;
	}
}
int kmp(){
	int cnt=0;
	int m=strlen(str1);
	int n=strlen(str2);
	if(n==1&&m==1){
		if(str1[0]==str2[0]) return 1;
		else  return 0;
	}
	getnxt();
	int j = 0;
	for(int i = 0;i<n;++i){
		while(j&&str2[i]!=str1[j]) j=nxt[j];
		if(str2[i]==str1[j]) j++;
		if(j==m){
			cnt++;
			j=0;
		} 
	}
	return cnt;
}
int main(int argc, char** argv) {
	while(~scanf("%s",str2)){
		if(!strcmp(str2,"#")) break;
		scanf("%s",str1);
		printf("%d\n",kmp());
	}
	return 0;
}

 

标签:字符,ch,重叠,int,布条,花纹,hdu2087,小饰条,kmp
来源: https://blog.csdn.net/qq_43472263/article/details/98757834