其他分享
首页 > 其他分享> > Master of Random

Master of Random

作者:互联网

题目描述

Hakase provides Nano with a problem. There is a rooted tree with values on nodes. For each query,you are asked to calculate the sum of the values in the subtree. However, Nano is a rookie so she decides to guess the answer. She has known how the data generator works: it identifi es the nodes with labels from 0 to n-1 and then visits them one by one. For each i (1≤i≤n), the generator selects a node whose label is smaller than i to be its father. The pseudocode is like this:
          for i = 1 to n - 1:
             father[i] = random(0, i - 1);
where random(a, b) randomly generates a uniformly distributed random integer in range [a, b].
Knowing n and the value of the i-th node ai , Nano decides to randomly choose a subtree and sum up all of the values in the subtree as the answer. Now Hakase wants to know what the expectation of the answer is. Can you help her?

 

输入

The first line contains an integer T (1≤T≤10) representing the number of test cases.
For each test case, the fi rst line contains an integer n (1≤n≤100000), the number of the nodes in the rooted tree.
The second line contains n integers a0,a1,...,an-1 (1≤ai≤100000) represent the values of nodes.

 

输出

It can be proven that the answer equals to an irreducible fraction p/q. For each test case, print p*q-1 mod 998244353 in one line. q-1 is the inverse of q under module number 998244353.

 

样例输入

复制样例数据

2
2
1 1
3
1 2 3

样例输出

499122178
166374063

 

提示

The shape of the tree in the fi rst test case is unique. The father of node 1 is 0. It is possible to choose node 0 or 1 with equal possibility. The sum of the subtree with 0 as the root is 2 while the sum of the subtree with 1 as the root is 1. So the expectation is (2 + 1)/2 = 3/2. The output is 3*2-1 mod 998244353 = 400122178.
There are two possible shapes in the second test case, node 1’s father destines to be 0, but node 2’s father might be node 0 or node 1. Both conditions are equally possible.
If node 2’s father is node 0, we randomly choose a node. The sum of the subtree with node 0 as the root is 6. The sum of the subtree with node 1 as the root is 2. The sum of the subtree with node 2 as the root is 3.
If node 2’s father is node 1, we randomly choose a node. The sum of the subtree with node 0 as the root is 6. The sum of the subtree with node 1 as the root is 5. The sum of the subtree with node 2 as the root is 3.
So the expectation is (6 + 2 + 3 + 6 + 5 + 3)/6 = 25/6. The output is 25*6-1 mod 998244353 = 166374063.

#include<bits/stdc++.h>
using namespace std;
typedef  long long ll;
const ll mod=998244353;
const int maxn=1e6+50;
#define lowbit(x)  x&(-x)
inline int read()
{
    int x=0,f=1;
    char ch=getchar();
    while(ch<'0'||ch>'9')
    {
        if(ch=='-')
            f=-1;
        ch=getchar();
    }
    while(ch>='0'&&ch<='9')
    {
        x=x*10+ch-'0';
        ch=getchar();
    }
    return x*f;
}
int gcd(int a,int b)
{
    return b?gcd(b,a%b):a;
}
ll qmod(ll a,ll b)
{
    ll ans=1;
    while(b)
    {
        if(b&1)
        {
            ans=(ans*a)%mod;
        }
        b>>=1;
        a=(a*a)%mod;
    }
    return ans;
}
ll inv(ll a)
{
    return qmod(a,mod-2);
}
int t;
int main()
{
    scanf("%d",&t);
    int n;
    while(t--)
    {
        scanf("%d",&n);
        ll tmp=1;
        for(int i=1;i<=n;i++)
        {
            tmp=tmp*i%mod;
        }
        ll op,tp=tmp;
        scanf("%lld",&op);
        ll ans=tmp*op%mod;
        for(int i=1;i<n;i++)
        {
            scanf("%lld",&op);
            tp=tp+tmp*inv(i)%mod;
            ans=(ans+tp*op)%mod;
        }
        tmp=tmp*n%mod;
        ans=ans*inv(tmp)%mod;
        printf("%lld\n",ans);
    }
    return 0;
}

 

标签:node,int,sum,Random,father,subtree,Master,root
来源: https://blog.csdn.net/weixin_41370251/article/details/89186031