其他分享
首页 > 其他分享> > 经典dp问题,求最大的连续字段和,求出并输出该子段和的起始位置

经典dp问题,求最大的连续字段和,求出并输出该子段和的起始位置

作者:互联网

原题:

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.<br>

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).<br>

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.<br>

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6

题目大意:求最大的连续字段和,求出并输出该子段和的起始位置。

解题思路:输入一串整数,记一个最大和summax,使其不断与前i个数的和比较若sum[i]>summax并记录开始与结束的位置,则使summax=sum[i];若sum[i]<0,则sum[i]=0并记录此时的位置为起始位置;此后不断循环最终得到所求结果。注意起始位置的记录。

感想:经典dp题,新手必做,刚开始的时候做还是有点困难。

源代码:

#include<iostream>
using namespace std;
int main(){
int n,c;
int a[100002];
scanf("%d",&n);
for(c=1;c<=n;c++){
int k=1,start=0,end=0,summax=-1000,sum=0;
int totalnum;
scanf("%d",&totalnum);
int a[totalnum];
for(int i=0;i<totalnum;i++){
scanf("%d",&a[i]);
}
for(int i=0;i<totalnum;i++){
sum+=a[i];//输入一串整数,记一个最大和summax,使其不断与前i
//个数的和比较sum[i]>summax并记录开始与结束的位置,则使summax=sum[i];
//若sum[i]<0,则sum[i]=0并记录此时的位置为起始位置,此后不断循环最终得到所求结果
//注意起始位置的记录
if(sum>summax){
summax=sum;
start=k;
end=i+1;
}
if(sum<0){
sum=0;
k=i+2;
}
}
printf("Case %d:\n%d %d %d\n",c,summax,start,end);
if(c!=n)cout<<endl;

}
}

 

标签:sequence,int,sum,start,字段,summax,line,该子,dp
来源: https://www.cnblogs.com/pesuedream/p/11276172.html