其他分享
首页 > 其他分享> > ZOJ 1002 Fire Net

ZOJ 1002 Fire Net

作者:互联网

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

在这里插入图片描述
Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.’ indicating an open space and an uppercase ‘X’ indicating a wall. There are no spaces in the input file.

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample input:

4
.X…

XX…

2
XX
.X
3
.X.
X.X
.X.
3

.XX
.XX
4




0

Sample output:

5
1
5
2
4

代码奉上:

#include<iostream>
using namespace std;
int n, i, j, ans;
char s[5][5];
int c_put(int n, int m){
	for (i = n - 1; i >= 0; i--){//行数 向前寻找
		if (s[i][m] == 'O')//如果有碉堡则产生冲突
			return 0;
		if (s[i][m] == 'X')//如果在遇到碉堡之前遇到了墙壁 则可以放 直接跳出循环
			break;
	}
	for (j = m - 1; j >= 0; j--){//列数 向前寻找
		if (s[n][j] == 'O')//如果有碉堡则产生冲突
			return 0;
		if (s[n][j] == 'X')//如果在遇到碉堡之前遇到了墙壁 则可以放 直接跳出循环
			break;
	}
	return 1;
}
void dfs(int k, int num){
	int x, y;
	if (k == n * n){//如果搜索到最后一格
		if (num > ans)//那么比较放置个数
			ans = num;
		return;//返回
	}
	else{
		x = k / n;//行数
		y = k % n;//列数
		//如果单元格可以放置
		if (s[x][y] == '.'&&c_put(x, y)){//判断是否为碉堡 是否产生冲突
			s[x][y] = 'O';//防止碉堡,并且标记
			dfs(k + 1, num + 1);
			s[x][y] = '.';
		}
		//如果单元格不可以放置
		dfs(k + 1, num);//否则就向下继续寻找;
	}
}
int main(){
	while (cin >> n&&n) {
		ans = 0;
		for (i = 0; i < n; i++){
			for (j = 0; j < n; j++)
				cin>>s[i][j];
		}
		dfs(0, 0);
		cout << ans << endl;
	}
}

标签:city,map,Fire,ZOJ,legal,int,num,1002,blockhouses
来源: https://blog.csdn.net/bjxqmy/article/details/96970327