其他分享
首页 > 其他分享> > HDU 4081 Qin Shi Huang's National Road System (次小生成树)prim

HDU 4081 Qin Shi Huang's National Road System (次小生成树)prim

作者:互联网

During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese. 


Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system: 
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang. 
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads. 
Would you help Qin Shi Huang? 
A city can be considered as a point, and a road can be considered as a line segment connecting two points.

Input

The first line contains an integer t meaning that there are t test cases(t <= 10). 
For each test case: 
The first line is an integer n meaning that there are n cities(2 < n <= 1000). 
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city. 
It is guaranteed that each city has a distinct location.

Output

For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.

Sample Input

2
4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40

Sample Output

65.00
70.00
#include <iostream>
#include <algorithm>
#include <math.h>
#include <vector>
#include<cstdio>
#include <cstring>
#include <queue>
#include<bitset>
typedef long long ll;

using namespace std;
const double inf=0x3f3f3f3f;
 const int maxn  = 2e5+100;
int dp[(1<<20)][20];

int n,k,m,flag;
int f[maxn],r[maxn];
bool vis[1005],used[1005][1005];//vis标记是否加入数,used用来判断某条边是否入树
double ma[1005][1005],dis[1005],po[1005],ans,mst;//ma存储i到j的路线上的最大值,dis存储prim里的最短边,po记录城市人口


 double g[1000][2],G[1000][1000];//g记录城市坐标,G记录i和j的距离
 int pre[1005];//记录结点入树时相连的父节点


double dis1(double a,double b,double c,double d)
{
    return sqrt((a-c)*(a-c)+(b-d)*(b-d));
}

void prim()
{
    memset(vis,0,sizeof(vis));
    memset(used,0,sizeof(used));
    memset(ma,0,sizeof(ma));

    for(int i=1;i<=n;i++)
    {
        dis[i]=G[1][i];
        pre[i]=1;
    }
    for(int i=1;i<=n;i++)
    {
        int u=-1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&(u==-1||dis[j]<dis[u]))
            {
                u=j;
            }
        }
        mst+=dis[u];
        vis[u]=1;
        used[u][pre[u]]=used[pre[u]][u]=1;//用来判断某条边是否已在树中
        for(int j=1;j<=n;j++)
        {
            if(vis[j]&&j!=u)
                ma[j][u]=ma[u][j]=max(ma[j][pre[u]],dis[u]);//已在生成树中的边,取j到u路线的最大值边即比较j到i和u到i的长度
            if(!vis[j]&&G[u][j]<dis[j])
            {
                dis[j]=G[u][j];
                pre[j]=u;
            }
        }

    }


}


int main()
{
    int q;
    scanf("%d",&q);
    while(q--)
    {
      cin>>n;
      for(int i=1;i<=n;i++)
      {
          double a,b,p;
          cin>>a>>b>>p;
          g[i][0]=a;
          g[i][1]=b;
          po[i]=p;
      }
      for(int i=1;i<n;i++)
        for(int j=i+1;j<=n;j++)
          {
              G[i][j]=G[j][i]=dis1(g[i][0],g[i][1],g[j][0],g[j][1]);//存储距离
          }
      mst=0,ans=-1;
      prim();
      for(int i=1;i<n;i++)
        for(int j=i+1;j<=n;j++)
          {
              if(used[i][j])
                ans=max(ans,(po[i]+po[j])/(mst-G[i][j]));//用魔法修建已在最小生成树里的边
              else
                ans=max(ans,(po[i]+po[j])/(mst-ma[i][j]));//直接用魔法修建i-》j的路,删去i-》j路线中的最长路
          }
         // cout<<mst<<endl;
      printf("%.2lf\n",ans);
    }
    return 0;
}

 

标签:4081,HDU,Qin,magic,Huang,Shi,include,road
来源: https://blog.csdn.net/qq_43256272/article/details/95028444