其他分享
首页 > 其他分享> > POJ 2393 Yogurt factory

POJ 2393 Yogurt factory

作者:互联网

Yogurt factory

Time Limit: 1000MS Memory Limit: 65536K

Description

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky’s factory, being well-designed, can produce arbitrarily many units of yogurt each week.

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt’s warehouse is enormous, so it can hold arbitrarily many units of yogurt.

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky’s demand for that week.

Input

Sample Input

4 5
88 200
89 400
97 300
91 500

Sample Output

126900
Hint

OUTPUT DETAILS:

In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units.

#include <iostream>
using namespace std;
typedef long long ll;
int main() {
	ll n, s, money = 0;
	cin >> n >> s;
	ll price[10010], num[10010];
	for (int i = 0; i < n; i++) cin >> price[i] >> num[i];
	money += price[0] * num[0];
	for (int i = 1; i < n; i++) {
		price[i] = min(price[i - 1] + s, price[i]);
		money += price[i] * num[i]; 	
	} 
	cout << money;
	return 0;
}

标签:price,units,num,POJ,2393,Yogurt,Line,yogurt
来源: https://blog.csdn.net/weixin_45031646/article/details/90241500