其他分享
首页 > 其他分享> > HDU1069-Monkey and Banana

HDU1069-Monkey and Banana

作者:互联网

Problem Description A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

InputThe input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
OutputFor each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题目大意
就给你n个箱子,输入每一个箱子的长宽高,每个箱子可以用无数次,要求你叠箱子,保证上一个箱子的长宽要小于
下面的箱子的长宽,注意不能等于,然后每个箱子的长宽高可以随意调换,问你最大的高度。

思路
先把数据做一次处理,每个箱子的放置可能性有6种,用结构体储存,然后通过长宽来排序,然后直接进行dp求最优。

代码
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define maxn 200
struct box
{
 int l,w,h;
}boxs[maxn];
int dp[maxn];
bool cmp(box a,box b)
{
 if(a.l==b.l)
 return a.w<b.w;
 return a.l<a.l;
}
int main()
{
 int n,flag=1;
 while(~scanf("%d",&n))
 {
  int len=0,a,b,c;
  for(int i=0;i<n;i++)
  {
   scanf("%d%d%d",&a,&b,&c);
   boxs[len].h=a;
   boxs[len].l=b;
   boxs[len++].w=c;
   boxs[len].h=b;
   boxs[len].l=a;
   boxs[len++].w=c;
   boxs[len].h=a;
   boxs[len].l=c;
   boxs[len++].w=b;
   boxs[len].h=b;
   boxs[len].l=c;
   boxs[len++].w=a;
   boxs[len].h=c;
   boxs[len].l=a;
   boxs[len++].w=b;
   boxs[len].h=c;
   boxs[len].l=b;
   boxs[len++].w=a;
  }
  sort(boxs,boxs+len,cmp);
  dp[0]=boxs[0].h;
  int max_h;
  for(int i=1;i<len;i++)
  {
   max_h=0;
   for(int j=0;j<i;j++)
   {
    if(boxs[i].l>boxs[j].l&&boxs[i].w>boxs[j].w)
    max_h=max(max_h,dp[j]);
   }
   dp[i]=boxs[i].h+max_h;
  }
  max_h=0;
  for(int i=0;i<len;i++)
  {
   max_h=max(max_h,dp[i]);
  }
  printf("%d\n",max_h);
 }
 return 0;
}

标签:Monkey,int,max,len,height,HDU1069,block,Banana,boxs
来源: https://www.cnblogs.com/tanwei-hq/p/10623421.html