L3-010 是否完全二叉搜索树 (30 分)
作者:互联网
L3-010 是否完全二叉搜索树 (30 分)
将一系列给定数字顺序插入一个初始为空的二叉搜索树(定义为左子树键值大,右子树键值小),你需要判断最后的树是否一棵完全二叉树,并且给出其层序遍历的结果。
输入格式:
输入第一行给出一个不超过20的正整数N;第二行给出N个互不相同的正整数,其间以空格分隔。
输出格式:
将输入的N个正整数顺序插入一个初始为空的二叉搜索树。在第一行中输出结果树的层序遍历结果,数字间以1个空格分隔,行的首尾不得有多余空格。第二行输出YES,如果该树是完全二叉树;否则输出NO。
输入样例1:
9
38 45 42 24 58 30 67 12 51
输出样例1:
38 45 24 58 42 30 12 67 51
YES
输入样例2:
8
38 24 12 45 58 67 42 51
输出样例2:
38 45 24 58 42 12 67 51
NO
代码
#include <bits/stdc++.h>
using namespace std;
struct BSTree
{
int val;
BSTree *left, *right;
BSTree()
{
left = right = nullptr;
}
BSTree(int v)
{
val = v;
left = right = nullptr;
}
};
BSTree* insert(BSTree *root, int v)
{
if(root == nullptr)
{
root = new BSTree(v);
}
else
{
if(root->val > v)
{
root->right = insert(root->right, v);
}
else if(root->val < v)
{
root->left = insert(root->left, v);
}
}
return root;
}
struct Node
{
int d;
int order;
BSTree *node;
Node(int _d, int _order, BSTree *n)
{
d = _d;
order = _order;
node = n;
}
bool operator<(const Node &a) const
{
if(d == a.d)
return order > a.order;
return d > a.d;
}
};
void layer_order(BSTree *root)
{
if(root == nullptr)
return ;
priority_queue<Node> pq;
pq.push(Node(0, 0, root));
vector<int> ans;
int d = 0;
int order = 0;
while(!pq.empty())
{
auto u = pq.top();pq.pop();
BSTree *node = u.node;
d = u.d + 1;
ans.push_back(node->val);
if(node->left != nullptr)
{
pq.push(Node(d, ++order, node->left));
}
if(node->right != nullptr)
{
pq.push(Node(d, ++order, node->right));
}
}
for(size_t i=0;i<ans.size();i++)
{
if(i!=0)
cout << " ";
cout << ans[i];
}
cout << endl;
}
bool is_cbst(BSTree *root, int n)
{
if(root == nullptr)
return true;
vector<bool> A(n+1, false);
queue<pair<int, BSTree*> > q;
q.push(make_pair(1, root));
A[1] = true;
int d = 0;
while(!q.empty())
{
auto u = q.front();q.pop();
d = u.first;
if(d <= n)
A[d] = true;
else
return false;
BSTree *node = u.second;
if(node->left != nullptr)
{
q.push(make_pair(2*d, node->left));
}
if(node->right != nullptr)
{
q.push(make_pair(2*d+1, node->right));
}
}
for(size_t i=1; i<A.size(); i++)
{
if(A[i] == false)
return false;
}
return true;
}
int main()
{
int n;
cin >> n;
int t;
BSTree *bst = nullptr;
for(int i=0;i<n;i++)
{
cin >> t;
bst = insert(bst, t);
}
layer_order(bst);
if(is_cbst(bst, n))
{
cout << "YES" << endl;
}
else
{
cout << "NO" << endl;
}
return 0;
}
标签:node,int,30,nullptr,010,L3,BSTree,root,order 来源: https://blog.csdn.net/weixin_43264529/article/details/88837200