其他分享
首页 > 其他分享> > 填涂颜色

填涂颜色

作者:互联网

enter image description here

输入

enter image description here

输出

已经填好数字 2的完整方阵。

样例输入
6
0 0 0 0 0 0
0 0 1 1 1 1
0 1 1 0 0 1
1 1 0 0 0 1
1 0 0 0 0 1
1 1 1 1 1 1
样例输出
0 0 0 0 0 0
0 0 1 1 1 1
0 1 1 2 2 1
1 1 2 2 2 1
1 2 2 2 2 1
1 1 1 1 1 1

用bfs将闭合圈之外的0染色 最后在反向输出就行了

#include<queue>
#include<bits/stdc++.h>

using namespace std;

int mp[100][100],vis[100][100],n;
int mx[5]={1,0,-1,0},my[5]={0,1,0,-1};

int main()
{
    cin>>n;
    
    queue <int> xv;
    queue <int> yv;
    xv.push(0);
    yv.push(0);
    vis[0][0]=1;

    
    for(int i=1;i<=n;++i)
    {
        for(int j=1;j<=n;++j)
        {
            cin>>mp[i][j];
        }
    }
    
    while(!xv.empty())
    {
        int tx=xv.front();
        int ty=yv.front();
        xv.pop();
        yv.pop();
        for(int i=0;i<4;++i)
        {
            int xx=tx+mx[i];
            int yy=ty+my[i];
            if(xx>=0&&xx<=n+1&&yy>=0&&yy<=n+1&&mp[xx][yy]==0&&vis[xx][yy]==0)
            {
                xv.push(xx);
                yv.push(yy);
                vis[xx][yy]=1;
            }
        }    
    }
    
    for(int i=1;i<=n;++i)
    {
        for(int j=1;j<=n;++j)
        {
            if(vis[i][j]==0&&mp[i][j]==0)
            {
                cout<<2<<" ";
            }
            else if(mp[i][j]==1)
            {
                cout<<1<<" ";
            }
            else
            {
                cout<<0<<" ";
            }
        }
        cout<<endl;
    }
    
    return 0;
}

 

标签:填涂,颜色,int,pop,vis,100,xv,yv
来源: https://www.cnblogs.com/XdzxBo/p/16622975.html