其他分享
首页 > 其他分享> > PAT Advanced 1036 Boys vs Girls(25)

PAT Advanced 1036 Boys vs Girls(25)

作者:互联网

题目描述:

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF​−gradeM​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

算法描述:模拟

题目大意:

给出整数n 以及 n个同学的信息(姓名 性别 学号 成绩)
第一行输出最低分男生的姓名和学号,第二行输出最高分女生的姓名和学号,第三个输出二者分差(男min - 女max)
如果没有某一性别的同学,则在相应行输出“Absent”,并在第三行输出“NA”

#include<bits/stdc++.h>
using namespace std;
string m_name = "Absent" , m_id , f_name ="Absent" , f_id ;
int m_grade = 101 , f_grade = -1;
int main()
{
    int n;
    cin >> n ;
    for(int i = 0 ; i < n ; i++ )
    {
        string name,id;
        char gender;
		int grade;
        cin >> name >> gender >> id >> grade ;
        if(gender == 'M' && (grade < m_grade || !i) )//性别 男 且 有更小成绩时
        {
            m_name = name ;
            m_id = id ;
            m_grade = grade ;
        }
        if(gender == 'F' && (grade > f_grade || !i) )//性别 女 且 有更大成绩时
        {
            f_name = name ;
            f_id = id ;
            f_grade = grade ;
        }
    }
    if(f_name == "Absent")  cout << f_name << endl ;
    else                    cout << f_name << " " << f_id << endl ;
    
    if(m_name == "Absent")  cout << m_name << endl ;
    else                    cout << m_name << " " << m_id << endl ;
    
    if(f_name != "Absent" && m_name != "Absent")    cout << f_grade - m_grade ;
    else                                            cout << "NA" ;
    return 0;
}

标签:25,PAT,name,Absent,grade,gender,Girls,line,id
来源: https://www.cnblogs.com/yztozju/p/16609186.html