其他分享
首页 > 其他分享> > POJ1458 Common Subsequence

POJ1458 Common Subsequence

作者:互联网

题目链接

题目

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

Source

Southeastern Europe 2003

题解

知识点:线性dp。

这题属于子序列系列题,这类题的特征是某个序列要符合某个特性,这里是两个序列相同。

可以设 \(dp[i][j]\) 为考虑到一串的第 \(i\) 个字母,二串的第 \(j\) 个字母的最长公共子序列。显然有转移方程:

\[dp[i][j] = \begin{cases} dp[i-1][j-1] + 1 &,s1[i] = s2[j]\\ \max (dp[i-1][j],dp[i][j-1]) &, s1[i] \neq s2[j] \end{cases} \]

时间复杂度 \(O(|s_1||s_2|)\)

空间复杂度 \(O(|s_1||s_2|)\)

代码

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

char s1[1007], s2[1007];
int dp[1007][1007];

int main() {
    std::ios::sync_with_stdio(0), cin.tie(0), cout.tie(0);
    while (cin >> s1 + 1 >> s2 + 1) {
        int len1 = strlen(s1 + 1);
        int len2 = strlen(s2 + 1);
        for (int i = 1;i <= len1;i++) {
            for (int j = 1;j <= len2;j++) {
                if (s1[i] == s2[j]) dp[i][j] = dp[i - 1][j - 1] + 1;
                else dp[i][j] = max(dp[i - 1][j], dp[i][j - 1]);
            }
        }
        cout << dp[len1][len2] << '\n';
    }
    return 0;
}

标签:sequence,int,s2,s1,subsequence,Subsequence,Common,POJ1458,dp
来源: https://www.cnblogs.com/BlankYang/p/16577853.html