其他分享
首页 > 其他分享> > ABC 263.C - Monotonically Increasing(dfs)

ABC 263.C - Monotonically Increasing(dfs)

作者:互联网

递归实现组合型枚举

Acwing原题:https://www.acwing.com/activity/content/19/

从 1∼n 这 n 个整数中随机选出 m 个,输出所有可能的选择方案。

输入格式
两个整数 n,m ,在同一行用空格隔开。

输出格式
按照从小到大的顺序输出所有方案,每行 1 个。

首先,同一行内的数升序排列,相邻两个数用一个空格隔开。

其次,对于两个不同的行,对应下标的数一一比较,字典序较小的排在前面(例如 1 3 5 7 排在 1 3 6 8 前面)。

数据范围
n>0 ,
0≤m≤n ,
n+(n−m)≤25
输入样例:
5 3
输出样例:
1 2 3 
1 2 4 
1 2 5 
1 3 4 
1 3 5 
1 4 5 
2 3 4 
2 3 5 
2 4 5 
3 4 5 

ABC这题就是把n和m反了一下而已

#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
int n,m;
int st[200200];
void dfs(int wz,int start)
{
    if(wz==m+1)
    {
        for(int i=1;i<=m;i++)
            cout<<st[i]<<" ";
        cout<<endl;
        return ;
    }
    for(int i=start;i<=n;i++)
    {
        st[wz]=i;
        dfs(wz+1,i+1);
        st[wz]=0;
    }
}
int main()
{
    cin.tie(0); cout.tie(0); ios::sync_with_stdio(false);
    cin>>n>>m;
    swap(n,m);
    dfs(1,1);
    return 0;
}

标签:输出,ABC,int,样例,dfs,263,include,Increasing
来源: https://www.cnblogs.com/Vivian-0918/p/16558190.html