其他分享
首页 > 其他分享> > TZOJ 4332:迷宫 广搜BFS

TZOJ 4332:迷宫 广搜BFS

作者:互联网

描述

 

迷宫可以被描绘成一个带有以下字符的矩形:

例如,一个小迷宫可能如下所示:

#前任###

 

你的工作是找到从“E”到“X”的最短路径(在“E”和“X”之间遇到的点数最少)。要从“E”到“X”,您只能乘坐“.”。人物。您只能向上、向下、向左或向右穿过迷宫。您不得沿对角线方向行驶。 

 

输入

 

输入数据将包含多个案例。每个case的第一行有两个整数R和C,分别代表迷宫的行数和迷宫的列数。2 < R, C < 50。
接下来的 R 行将包含构成该行的 C 个字符,即 'E's、'X's、'#'s 或 '.'s。
 

 

输出

 

对于每种情况,输出一个整数,即每行从“E”到“X”的最短路径。
 

 

样例输入

 

5 5
#E###
#...#
###.#
#...#
#X###

样例输出

7

AC感想:BFS模板题,难度不高,注意多组数据所以要清除标记数组,还有注意地图范围以及队列范围

#include<bits/stdc++.h>
using namespace std;
struct node{
    int x,y,step;
};
node q[3000];
char a[55][55];
bool book[55][55];
int nex[4][2] = {{0,1},{1,0},{0,-1},{-1,0}};
int n,m,ans,f,sx,sy,ex,ey,sf;

void bfs()
{
    int tx,ty,head,tail;
    head = tail = 1;
    q[tail].x = sx;
    q[tail].y = sy;
    q[tail].step = 0;
    book[sx][sy] = 1;
    tail++;
    while(head<tail)
    {
        for(int i=0;i<4;i++)
        {
            tx = nex[i][0]+q[head].x;
            ty = nex[i][1]+q[head].y;
            if(tx<1||ty<1||tx>n||ty>m)continue;
            if(a[tx][ty]!='#'&&book[tx][ty]==0)
            {
                book[tx][ty] = 1;
                q[tail].x = tx;
                q[tail].y = ty;
                q[tail].step = q[head].step+1;
                tail++;
            }
            if(tx==ex&&ty==ey)
            {
                f = 0;
                ans = q[tail-1].step-1;//-1是因为这个step已经是包含了终点的步长,题目要求了不计算到终点的步长 
                break;
            }
        }
        if(f)break;
        head++;
    }
}
int main()
{
    while(cin>>n>>m)
    {
    memset(book,0,sizeof(book));
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
        {
            cin>>a[i][j];
            if(a[i][j]=='E')
            {
                sx = i;sy = j;
            }
            if(a[i][j]=='X'){
                ex = i;ey = j;
            }
        }
        getchar();
    }
    f = 0;
    ans = 0;
    bfs();
    cout<<ans<<endl;
    }

     return 0;
}

 

标签:tx,ty,int,迷宫,4332,step,BFS,tail,TZOJ
来源: https://www.cnblogs.com/jyssh/p/16391913.html