其他分享
首页 > 其他分享> > PAT Basic 1003 - 我要通过!

PAT Basic 1003 - 我要通过!

作者:互联网

Problem

答案正确』是自动判题系统给出的最令人欢喜的回复。本题属于 PAT 的『答案正确』大派送 —— 只要读入的字符串满足下列条件,系统就输出『答案正确』,否则输出『答案错误』。

得到『答案正确』的条件是:

现在就请你为 PAT 写一个自动裁判程序,判定哪些字符串是可以获得『答案正确』的。

Input

每个测试输入包含 1 个测试用例。第 1 行给出一个正整数 \(n\) \((\le 10)\),是需要检测的字符串个数。接下来每个字符串占一行,字符串长度不超过 100,且不包含空格。

Output

每个字符串的检测结果占一行,如果该字符串可以获得『答案正确』,则输出 YES,否则输出 NO

Sample Input

10
PAT
PAAT
AAPATAA
AAPAATAAAA
xPATx
PT
Whatever
APAAATAA
APT
APATTAA

Sample Output

YES
YES
YES
YES
NO
NO
NO
NO
NO
NO

Solution

字母 PT 将整个字符串分成三段。根据题意,当第一段的长度乘以第二段的长度等于第三段的长度时,答案正确。

#include <iostream>
#include <string>

using namespace std;

bool isCorrect(const string& s) {
    int indexP = -1;
    int indexT = -1;
    for (int i = 0; i < s.size(); i++) {
        if (s[i] != 'P' && s[i] != 'T' && s[i] != 'A')
            return false;
        if (s[i] == 'P')
            indexP = i;
        if (s[i] == 'T')
            indexT = i;
    }

    int l1 = indexP;
    int l2 = indexT - indexP - 1;
    int l3 = s.size() - indexT - 1;
    if (l2 == 0)
        return false;
    else
        return l1 * l2 == l3;
}

int main() {
    int n;
    cin >> n;

    string s;
    for (int i = 0; i < n; i++) {
        cin >> s;
        if (isCorrect(s))
            cout << "YES" << endl;
        else
            cout << "NO" << endl;
    }

    return 0;
}

标签:PAT,正确,NO,int,我要,答案,字符串,YES,1003
来源: https://www.cnblogs.com/Not-Even-Wrong/p/16320771.html