九度OJ题目1049-字符串去特定字符
作者:互联网
题目描述:
输入字符串s和字符c,要求去掉s中所有的c字符,并输出结果。
输入:
测试数据有多组,每组输入字符串s和字符c。
输出:
对于每组输入,输出去除c字符后的结果。
样例输入:
heallo
a
样例输出:
hello
来源:
2009年哈尔滨工业大学计算机研究生机试真题
参考代码:
#include<cstdio>
#include<cstring>
using namespace std;
#define N 1001
char s[N];
char buf[N];
int main() {
while (scanf("%s", s) != EOF) {
int len = strlen(s);
char tmp[2];
scanf("%s", tmp);
int cnt = 0;
for (int i = 0; i < len; i++) {
if (s[i] != tmp[0]) {
buf[cnt++] = s[i];
}
}
buf[cnt] = '\0';
printf("%s\n", buf);
}
return 0;
}
标签:tmp,字符,cnt,OJ,int,1049,char,九度,buf 来源: https://blog.csdn.net/sinat_38292108/article/details/88343940