其他分享
首页 > 其他分享> > 7-6 符号配对 (20 分)(C语言版)

7-6 符号配对 (20 分)(C语言版)

作者:互联网

请编写程序检查C语言源程序中下列符号是否配对://、(与)、[与]、{与}。

输入格式:
输入为一个C语言源程序。当读到某一行中只有一个句点.和一个回车的时候,标志着输入结束。程序中需要检查配对的符号不超过100个。

输出格式:
首先,如果所有符号配对正确,则在第一行中输出YES,否则输出NO。然后在第二行中指出第一个不配对的符号:如果缺少左符号,则输出?-右符号;如果缺少右符号,则输出左符号-?。

输入样例1:

void test()
{
    int i, A[10];
    for (i=0; i<10; i++) { /*/
        A[i] = i;
}
.

输出样例1:

NO
/*-?

输入样例2:

void test()
{
    int i, A[10];
    for (i=0; i<10; i++) /**/
        A[i] = i;
}]
.

输出样例2:

NO
?-]

输入样例3:

void test()
{
    int i
    double A[10];
    for (i=0; i<10; i++) /**/
        A[i] = 0.1*i;
}
.

输出样例3:

YES

鸣谢用户 王渊博 补充数据!

#include<stdio.h>
#include<stdlib.h>
#define N 1000
int main()
{
    char stack[N];
    int top=-1;
    char str[N];
    int j=0;
//     int flag1=1,flag2=1;
    gets(str);
    while(str[0]!='.') {
		j=0;
        while(str[j]!='\0') {
            if(str[j]=='/'&&str[j+1]=='*') {
                stack[++top] = str[j++];
                stack[++top] = str[j++];continue;
            }else if(str[j]=='*'&&str[j+1]=='/'){
                if(top!=-1&&stack[top]=='*'&&stack[top-1]=='/'){
                    top-=2;
                    j+=2;continue;
                }else{
                    printf("NO\n");
                    if(top==-1){
                        printf("?-%c%c",str[j],str[j+1]);
                    }else {
                        printf("%c-?",stack[top]);
                    }
                    return 0;
                }
            }else if(str[j]=='('||str[j]=='['||str[j]=='{') {
                stack[++top] = str[j++];continue;
            }else if(str[j]==')'){
                if(top!=-1 && stack[top]=='('){
                    top--;
                }else{
                    printf("NO\n");
                    if(top==-1){
                        printf("?-%c",str[j]);
                    }else{
                        printf("%c-?",stack[top]);
                    }
                    return 0;
                }
            }else if(str[j]==']'){
                if(top!=-1 && stack[top]=='['){
                    top--;
                }else{
                    printf("NO\n");
                    if(top==-1){
                        printf("?-%c",str[j]);
                    }else{
                        printf("%c-?",stack[top]);
                    }
                    return 0;
                }
            }else if(str[j]=='}'){
                if(top!=-1 && stack[top]=='{'){
                    top--;
                }else{
                    printf("NO\n");
                    if(top==-1){
                        printf("?-%c",str[j]);
                    }else{
                        printf("%c-?",stack[top]);
                    }
                    return 0;
                }
            }
            j++;
        }
        gets(str);
    }
    if(top==-1){
        printf("YES");
    }else{
        printf("NO\n");
        printf("%c-?",stack[top]);
    }
    return 0;
}


声明:代码转载,侵权即删。

标签:20,NO,top,C语言,str,printf,else,配对,stack
来源: https://blog.csdn.net/qq_54210270/article/details/123335150